Email links don’t work if Safari is disabled

Hi all. I’m a brand new Brave user and love it! However, (I apologize if this has already been discussed. I looked but couldn’t find anything) I want Brave to be the default, so I disabled Safari via Screen Time. But when I did, email links quit working. I’ve had to re-enable it but would love to do something so that Safari NEVER picks up. Is there a way?

Hi, @Oldsquid. Since you mention Screen Time, I presume you’re using Brave on an iOS device, not a Mac. To date, there’s no way to change the default browser in iOS to something other than Safari. I tried also adding Brave to the “Always allowed” category, but that sill wound up with tapped links in e-mail messages not doing anything. However, a workaround is to hold your finger on the link to call up a contextual menu that offers the option to copy the link. Then you can switch to Brave and paste the link into a new tab. It’s more work, but it avoids Safari.

:unamused: Bummer! But thanks anyway. I know Apple, like Windows, is pretty “Big Brother” about stuff so I’m not really surprised. Future enhancement maybe?

1 Like