DuckDuckGo search automatically redirects to google in incognito mode

Description of the issue:
I turned on the option to search with duckduckgo in private browsing mode. However, when type something in and hit enter, it redirects me to google search instead of duckduckgo search

How can this issue be reproduced?

  1. Open brave browser in private mode
  2. Type in anything and search

Expected result:
Will redirect you to google search instead of duckduckgo

Brave Version:
v 1.11.97, on windows 10 home

Additional Information:
If I press ctrl+E, it will show “Search DuckDuckGo”, but will redirect me to google otherwise, which is quite annoying.

I don’t seem to be having this issue. Are you sure you have enabled the DuckDuckGo switch on the incognito tab? ; as shown here:

Yes, of course I did.

There doesn’t seem to be a problem now though, I fixed it by resetting the browser.