Disabling Javascript on developer tools has no effect

I use Brave as my main browser, even for web development, and as the title says, when I try to disable JS on the developer tools, this action has no effect. JS keeps running and the content inside <noscript> tags is never rendered.


Might you provide each step, on how to “disable JS on the developer tools”? Thanks.

I am wondering what steps you take, because I have used the

Brave Browser menu bar >> View >> Developer >> Developer Tools

selection, in order to display the Developer Tools window. And then, I have been trying to find the switch in that window, that Enables / Disables Javascript ?

1 Like

@orballo I’m having the same issue, JavaScript always runs even after I disable it. @289wk to turn it on you can do View > Developer > Developer Tools, then hit Shift+Command+p on your keyboard, then type “disable javascript” and then refresh the browser. In Chrome this disabled JavaScript, but in Brave it has no effect, except when I go through these steps again then “disable javascript” is no longer an option but instead only “enable javascript,” making it seem like it’s trying to do the right thing.

Upon further testing, I noticed the above does work if I have Brave’s “site shield up,” but that means I have to re-enable it for my local development environment where I’d like to turn the shield off always.


News to me; thank you:

“View > Developer > Developer Tools, then hit Shift+Command+p on your keyboard”

We haven’t changed from the default settings in Chrome, does it occur there also?

This may be a dumb question, but since I can’t find View anywhere, is this the same as Menu > More tools > Developer tools (ctrl+shift+i)? Because something similar seems to be happening for other dev tools: Developer Tools - devices choice no longer being saved


Brave Browser menu bar - Mac OS “Sierra”


Yes, that’s the same menu. Then, if you hit shift+ctrl+p for Windows I imagine the menu will come up to type the command I referenced.

1 Like

It does. And with shields up, it indeed does enable/disable JS, until you close DevTools and then resets.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.