Disable Back and Forward Navigation with Scroll on Apple MBP

My problem:
I have recently moved from Chrome to Brave and one of the things that I really hate about both browsers is the back and forward navigation using the 2-finger side-scroll gesture. It makes using web applications that require sideways scrolling super frustrating to use. Back navigation also invariably happens when scrolling down a long article / publication / web page.
I understand that web developers might be able to fix the web pages that require side scrolling but I don’t see the point of this useless gesture based navigation feature. The good old fashioned back button is good enough for me.

My question:
Is there some way to disable this awful feature?

Steps to reproduce:

  1. Navigate to https://www.instagram.com/p/B42aieOhkPe/
  2. With the mouse cursor over the beach scene image and using a to finger gesture, first scroll toward the right of the trackpad to the next image.
  3. With the mouse cursor over the beach scene image and using a to finger gesture, first scroll toward the left. The Browser invokes back navigation! Arghh!

Example:
GIF of unintended back navigation: https://imgur.com/T5Mogb6

Expect:
Don’t navigate backward.

How often:
This happens too often. How do I disable it forever?

My Device:
MacBook Pro (Retina, 15-inch, Mid 2014)
macOS High Sierra (10.13.6)
Brave Browser (Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit))

@professor.bokdrol,
Is it safe to assume that you do want to have this functionality active – just not for Brave (or any browser)?

Nope, Brave is currently my primary browser. I don’t want to change my trackpad config in system preferences.

I want Brave to stop navigating back when I use the 2 finger left scroll gesture. I also want Brave to stop navigating forward when I use the 2 finger right scroll gesture.

I want the 2 finger scrolling gestures to result in just that, scrolling.

@professor.bokdrol,
It appears that the flag to disable this feature was removed from the Chromium backend – not entirely sure why. But I’m seeing the same behavior for both Chrome and Chromium as well. So there’s no way to alter this at this time.

I would suggest leaving a feature request here on Community to include it.

Thanks @Mattches. I will log the feature request as you suggest :slight_smile:


Hope that helps

3 Likes

Thanks again. I am scrolling left just for fun now. :smiley: Wow! So good!

2 Likes