Desktop Sync Chain


I’m trying to sync my desktop to a chain that contains my Iphone and Ipad, however, I’m getting this error. How can I solve it?

@mattches please assist. Thanks!

1 Like

Are you successfully syncing your device to the chain to begin with? That is, do you see it on the list of devices on the chain? If so, is it that no data is syncing between your desktop and the other devices or some of it is and some isn’t?

The iPhone and iPad are syncing normally, however, when I add the desktop the syncing tab, on the desktop, freezes and when i reload it I don’t see neither the other devices in the chain nether the desktop on my iPhone.

Are you using the Sync code to Sync your Desktop device to your iOS devices?

@Mattches Yes, I generate using the iPhone, send it to the desktop and paste it.
I can share printscreens or the logs from the browser if you prefer.

This is what I see on my iPhone after adding the Desktop.

This is what I see on my desktop.

Hello @TheSupercao ,

It seems something is wrong with the desktop client, the sync server refuses it’s connection.
I am not 100% sure, but I saw similar situation with browser builds which didn’t contain the Brave Services key. Or the Sync server url was wrong. These two cases for me were result of build with wrong parameters and must not be a case for the published builds. I would like to double check this,

Could you please share Version Info section from brave://sync-internals/ ? Mine looks as
image .

Also which OS do you use, Windows/Linux/macOS?


Hey Alexey mine is:

I’m on a windows.

1 Like

Thanks @TheSupercao

Server URL is wrong.

The correct must be

The workaround is to launch browser with additional argument



%HOMEPATH%\AppData\Local\BraveSoftware\Brave-Browser\Application\brave.exe --sync-url="" 

Figuring out why this happened.

@Alexey for some reason I try to add it on my shortcut and didn’t work

Updated browser on my Windows device - the url wasn’t changed to chrome-sync.sandbox.... I will try to check a clean install.

Hm, could you please put here the screenshot of about:version page?

Also, just in case, did you change any flags at brave://flags/ , especially something sync-related ?

probably is the second no? :sweat_smile:

1 Like

Deactivated the use chrome sync sandbox, under brave://flags/, and it worked!

1 Like

ah, :joy: well, yeah.
It seems you have understand the reason.

Why did you enable it?

I dont remember, could it be to use chromecast?

Thanks, no worries.

I think this is not related to chromecast.
This flags has meaning for Google Chrome and Chromium and enabling it means the browser will use Google test servers instead of the production servers. This is not applicable for Brave sync.

Maybe we should hide this flag, as it doesn’t have any point for Brave Browser.