Delete specific suggested urls in address bar like chrome

When opening a new tab and starting to type an URL (e.g. youtube.com), often the first (on top) suggested link is something else (e.g. a link to a youtube video) instead of the main page (youtube.com). I’m guessing i had this link bookmarked at some point. I am unable to delete this link, or any other suggested links for that matter. This can get very annoying as i always end up navigating to the first suggested link (which in the youtube example is a removed video)

Steps to Reproduce (add as many as necessary):

  1. Open a new tab by pressing the ‘+’ and start typing
  2. Brave will autosuggest a few links based on your input
  3. Try deleting them (as you would in Chrome for example) with down arrow to select instance, then shift + delete

Actual Result (gifs and screenshots are welcome!):
Only removes the test typed in the address bar and not the link

Expected result:
Should be able to delete any specific autosuggested link

Reproduces how often:
Always

Brave Version(See the About Brave page in the main menu):
Version 1.11.97 Chromium: 84.0.4147.89 (Official Build) (64-bit)](https://brave.com/latest/)

Reproducible on current live release (yes/no):
Yes

Additional Information:

1 Like

Hi @metabee, Welcome to Community!
Can you try copying the URL you don’t want, going to your history, searching with the URL and then deleting the search results?

In my history there are more than 300 hits after the search. Do I have to select each of those individually and then delete? It’s not worth all that work.

The Brave shortcuts article mentions the shift + delete should work.

If you select one and then hit cmd+a, that will select all
also be sure to scroll down to make sure all items in the list are loaded, so it can be selected

After deleting all the instances that mach my search query in a History tab, the URL is no longer suggested as expected.
I see now there is also a cross next to the suggestions in the url (probably added recently) that does what I wanted it to do.
The shift + delete button also does what i expected it to do now.

Don’t know if this was fixed or if the problem went away.

Oh nevermind I got the issue again.
The x is not shown on the suggestion at all now, but if I remove the logs from the history it’s gone.

If you go to brave://settings/appearance you can disable Show autocomplete in address bar, this won’t remove one item, it will stop everything for showing up.
But you can also test out Show top sites in autocomplete suggestions to see if that can remove the site you don’t want showing up.

Thank you for this suggestion. This is the one I needed.

I had a problem where unrelated websites, that I’ve never visited before, were showing up as suggestions whenever I typed something in the search bar.
For example, I would type “yt” (as my custom search engine) and below that Brave would suggest “nytimes.com” and “babytree.com” (which I know I’ve never seen or heard of because it’s a Chinese site for baby care).

I also tried the Shift+Del method to delete suggestions, as well as enabling the #omnibar-suggestion-transparency-options flag to show an X button for deleting the suggestion. Neither were successful for removing the site suggestions.

The answer seems to be that it’s part of the Show top sites in autocomplete suggestions, found in brave://settings/appearance. I turned that off and they’re gone now.

It was a bit weird that, as a plain English user, I was being suggested “babytree.com” which is a Chinese website. But I guess that shows Brave doesn’t care about my location.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.