Crash when using Qwant on Android

Hi everyone !

I hope you’re all well ?

Here’s my problem :

I encounter a problem since 2 or 3 versions of Brave, with Qwant search.

For the first search (in the url/search field, see picture) => no problem. But when I want do add something to refine, on Qwant itself (see picture with “test” in the search field) the browser crashes.

I don’t know if it is a script that makes Brave crash or something else.

How can this issue be reproduced?

  1. Go on Qwant.com
  2. Try to type something in the search field
  3. It crashes :slight_smile:

Expected result:

Brave doesn’t crash ^^

Brave Version( check About Brave):

Brave 1.30.87 (Chromium 94.0.4606.71)

Mobile Device details

Samsung S10e with Android 11; Build/RP1A.200720.012 and all softwares up to date.

Additional Information:
None

Thanks !

2 Likes

Had no issues here, no crashes seen with a few searches. Maybe try clearing the app cache for Brave?

Hi ! Thank you for the answer.

Still doesn’t work even with the cache cleaned :-/

I don’t know if it could be another component (script or so) that makes Brave crash ? I’ve tried with Google chrome => same problem but not with duckduckgo browser.

Could the Chromium engine be a problem (or the libraries it relies on) ?

1 Like

I’m here with the same issue on 2 devices.

How to reproduce:

  1. Go to Qwant.com mobile
  2. search something
  3. select search bar on the result page to input something else
  4. Crash

It always crashes the second time searching (on the first search’s result page). When the page is restored after a crash, you can once again search 1 time, even on the previous search’s result page. The second time however the browser crashes again. The Brave search button does work on every search, it’s specifically the search input field on the Qwant mobile website. Desktop mode works fine too.

Brave Version device 1
Brave 1.30.87. Chromium 94.0.4606.71
Mobile Device details 1
A Xiaomi mipad4 with Android 10; Build/QQ3A.200805.001

and
Brave Version device 2
Brave 1.30.87. Chromium 94.0.4606.71
Mobile Device details 2
A Samsung Galaxy A50 with Android 11; Build/RP1A.200720.012

1 Like

Hi. Same behavior here. Brave will instantly crash when taping on the Qwant search field.
Brave version: 1.30.87
OS version: Android 11
Hardware: Samsung Galaxy S20

Cheers

Hi,
Please see also my answer in the discussion. Same issue, as other users. It has been a few months now.

Which question to me? Its a near midnight here, but tested on 2 phones, one Galaxy ZFold 3 (Android 11) and a Oneplus 6 (Android 10):

I have raised the issue with some Android devs, they’re investigating it

1 Like

@Max75 @Callewsa If you’re using a password manager (lastpass, 1password etc) This could be related too: https://stackoverflow.com/questions/69428809/chrome-crash-attempt-to-invoke-virtual-method-long-android-view-accessibility

Try re-installing the password manager as an option (or disable/uninstall temporarily just to see if it helps)

1 Like

Hi fanboynz,
Good guess! LastPass was indeed guilty. I uninstalled it and it now works fine.
The behavior only occurs with Qwant, it works fine wih DuckDuckGo.
Cheers

Try installing LastPass again, see if it still occurs

I reinstalled LastPass. Working fine but the moment I authorized autofill, Brave started crashing again. Looks quite similar to the behavior described in your link.

I’m using Bitwarden as a password manager and can confirm disabling autofill solves the crashing. Reenabling it sadly makes the crashes to return.

Update : when autofill is disabled (I’m using Dashlane) everything works fine !

When enabled => Qwant crashes again.

So, I do not really consider this problem as solved :wink: