CPU Overdrive on Macbook Pro + Air

I am running Mac OS Ventura developer beta 2 on one macbook pro and monterrey on a macbook air with both producing the same results with the latest brave browser update. i have close to 50 tabs on a browser and single tab on another and still have the cpu running on overdrive with the fans running at this highest speed possible as if I am doing some heavy computation. I am currently back to using google chrome and cpu operating speed is back to normal. Brave browser is currently unusable at this point as it is currently stands. Restart of browser and computer has also not made the issue any better.

Brave Version 1.40.107

@gixak

Try . . .

Go to: brave://flags/:

  • DISABLE: Enable Brave News
  • DISABLE: Brave News prompts on New Tab Page
  • DISABLE: Experimental QUIC Protocol

Go to: brave://settings/system

  • DISABLE: Use hardware acceleration when available

Go to: brave://settings/shields

  • DISABLE: Auto-redirect AMP pages
  • DISABLE: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Agressive
  • Enable: Upgrade connections to HTTPS (HTTPS EVERYWHERE toggle switch)
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Go to: brave://settings/security

  • DISABLE: Always use secure connections (HTTPS ONLY toggle switch)
  • DISABLE: Use secure DNS

Reduce influence by websites:

Go to: brave://settings/content

Scroll down to Additional permissions . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to Content . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • DISABLE: Clear cookies and site data when you close all windows

Go to: brave://settings/clearBrowserData

For tab Basic:

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Clear DNS cache:

Using a Brave Browser > New Window, go to: brave://net-internals/#dns

  • Click on: Clear host cache

Close idle sockets and Flush socket pools:

Go to: brave://net-internals/#socket

  • Click on: Close idle sockets
  • Click on: Flush socket pools

Exit / Quit Brave Browser.

RESTART COMPUTING DEVICE

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

Test Brave Browser > New Window

-vs

Brave Browser > New Private Window

Disable all Extensions

Enable each Extension, so it is alone, one-at-a-time.

hmmmh. odd because i dont see a brave update but yet problem has now gone away. i have had my network compromised in the past before so perhaps something similar has happened again and they removed whatever operation was going on my devices as it became noticed by me with the impacted performance. keep me up to date if there was an update by brave as I did nothing.

I have the same issue, CPU 100% and it never goes down.
I can only close the browser with “Force Quit”.

I have Brave Browser Dev (blue icon) Version 1.42.79 Chromium: 103.0.5060.134 (Official Build) dev (x86_64)

This CPU issue must have started recently, I only noticed it yesterday.

EDIT: I tried all the configs suggested in the post above, it didn’t help.

@gixak , @andreoliwa

https://www.chromium.org/developers/memory-usage-backgrounder/

Multi-Process Model Background

To understand Chromium’s memory usage, let’s understand the multi-process model. Unlike other browsers, Chromium is divided into multiple processes.

When Chromium starts up, it will initially have two processes. One process is the browser process which controls the main browser functionality, and the other is the initial renderer process , which runs the Blink rendering engine and JavaScript (V8).

Each time you open a new tab in Chromium, you’ll likely get a new renderer process. With typical browsing, it is common to see 5-7 chrome.exe processes active.

Further, if you utilize plugins, apps, or extensions, they may also execute within independent processes.

All of Chromium’s processes, whether it is a browser process, a renderer process, or a plugin process, will show under the Task Manager as ‘chrome.exe’.

Comparison: CPU & GPU Usage of 4 Browsers

https://helgeklein.com/blog/comparison-cpu-gpu-usage-4-browsers/

In their conclusion:

The efficiency of the browser vendors’ GPU implementations depend more on the driver and the type of [browser] optimization than on raw hardware power.


Article from 2018:

How to Stop Chrome From Using All Your CPU

https://techstacker.com/how-to-stop-chrome-from-using-all-your-cpu/lfi7ynpxnttxajszg/

Thanks for the help again.
The problem persists, I will keep trying.

Only “Brave Browser Dev” has the CPU problem, not the stable Brave Browser.

  • Yesterday I tried most (or all) of the setting mentioned in the post above
  • Rebooted yesterday (after 51 days uptime)
  • Disabled hardware acceleration
  • Disabled all Chrome extensions (didn’t remove them as the article suggests; only disabled)
  • Today I tried the tips from the article above How to Stop Chrome From Using All Your CPU
  • Chrome Task Manager says the “Browser” itself is the problem, not tabs, not extensions, not GPU process
  • Computer is not very old: a MacBook Pro from 2019
  • I’m still on macOS Big Sur 11.6.6 though; maybe that is an (or the) issue

I’ll try upgrading macOS and post here again.
Thanks once more for the tips!

1 Like

Upgrading macOS to Monterey didn’t solve the 100% CPU issue.

Problem solved: I replaced Brave Browser Dev with Brave Browser Beta.
Now my laptop fan is finally silent after days of engine noise.

Something is weird with the Dev version. Maybe it’s discontinued?
The Brave Dev link on Homebrew even redirects to the Brave Beta page.

❯ brew info brave-browser-dev
brave-browser-dev: 1.42.66.0,142.66 (auto_updates)
https://brave.com/download-dev/
Not installed
(...)

❯ brew info brave-browser-beta
brave-browser-beta: 1.42.65.0,142.65 (auto_updates)
https://brave.com/download-beta/
/usr/local/Caskroom/brave-browser-beta/1.42.65.0,142.65 (132B)
(...)