Constantly getting "Page Unresponsive"

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

This is the biggest complaint I have about Brave Browser and its like using a crippled browser that only works part of the time.
This happens on a lot of websites and the sites work fine on google chrome.

Most recently this was the problem on when I tried to sign into

What is causing this?? How can it be fixed??

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:


Try this : go to brave://settings/security and disable secure dns

I am also getting page unresponsive on many (not all) sites. If I turn off the shields, it loads fine. If I go to a private window, it loads fine. These pages work in IE so it’s something to do with Brave. Amazon is one of the sites it’s happening too. And it’s only been happening in recent days. I’m on Windows 10 laptop.

Same for me. Amazon is now completely unusable with Shields on. I’m on Linux Mint and whatever happened in this latest update has made the browser pretty much useless for me. Been using it since 2019 and never seen any performance hit like this. I’ve switched back to Chromium & FF with adblock/ublock. Turning hardware acceleration off didn’t resolve the problem for me.

@CerealLover Do you know anything about the Custom options? Can one of those be selected instead of disabling secure DNS entirely?


I have this same problem. It’s been happening for weeks on select sites. For example, When first loading the page to log in, it just gets stuck until the Page Unresponsive pops up. After a while, I am able to enter my login information, but then the process repeats when prompted for the verification code. This happens only with Brave, but on all OSs (Windows 10, Windows 11, Mint). Disabling secure DNS did not help.

I did some research in the community and found a solution. Switching the Shields to Aggressive mode seems to have resolved this issue for me.
-Click on the Brave Shield
-Click on Change global shield defaults
-Change Trackers & ads blocking to Aggressive

Does switching to Shields=Aggressive help @alan93 ?

I don’t see a “security” so how do I do this? Can’t you be more specific?

what does switching shields to aggressive mean? Can’t you explain this more? Why does everyone assume that users know everything they know?

where is this view at??

brave://settings/security under “Advanced” heading in the With Custom dropdown.

And even though you tagged fanboynz… per Shields = Aggressive
brave://settings/shields under “Look & feel” heading select the dropdown forTrackers & ads blocking.

You can use search in settings and it will pull up instances of the keyword(s) you enter. Example screenshots below.

Search (magnifying glass) on the far right of menu bar.

Click Search and enter keyword.

All the instances with keyword will be highlighted/displayed.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.