Unresponsive page on a single site

I have been using brave for a number of years. Since yesterday 26/10/2022, when I try to go onto a specific website (Bybit.com), I get an unresponsive page. Brave works with all other sites as normal. I tried Bybit in chrome and no issues.

having exactly the same issue with that same specific site … reached bybit support who told me bybit works best w/firefox or google chrom… ive tried using these navigators :thinking:, same issue ! kind of stuck right now…

I tried it on chrome and works fine. I would prefer to use brave for all my internet usage. so weird that it only started a few days ago.

Same issue here, i think it’s the problem with the latest brave browser update that caused it!

yes i’ve tried w/firefox … works fine… no way im gonna install google chrome… annoying …and i also believe it is since the recent Brave updates …

Trying to reach out to them, Even with shields disabled there is much delay.

Free to also reach out and ask for a fix.

Things seem to be work much better now. Anyone else still have the same issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.