CloudFlare Challenge get stuck in Infinite Loop

Hello Team,

Got this issue out of the blue after a brave update to v1.21.74 and a weird bug.
My laptop at some point lost internet connexion. what ever the wifi i would connect to (100% working wifis on other phone/computer) i would got an error like i don’t have internet connexion.
after a reboot same. at this point my brave issue was still unaware.
At some point i’ve started my VPN software and just like that my internet connexion would be back up again.
Turning off the VPN the connexion looks still up, but that’s where my brave issue occur on one specific web site.

Sees below :

On website the Cloudfare ddos protection just load and load in a loop and never clear.
I can see the Ray ID changing after what would be the amount of time it usually takes to clear it.

I don’t really know how to reproduce the bug.
It doesn’t change any thing in a private windows and clearing cache/cookies/whatever of the target url doesn’t do the trick either for normal browsing.

The website works fine while using an other browser on the same laptop.

After the bug other website using Cloudfare would also display the same behaviour, but then after a simple refresh it would clear it and let the browser access the exchange.

not sure how to debug this and the lack of specific key words make it hard to seek for solutions.

If you have any idea about this i would gladly test it.
Using chrome to just access this exchange feel already like a pain…


Edit : updated to 1.21.77, but still the same

Hey, just tested the site (correction, also test ) and it loaded fine here. Can you test from a new profile? what error message are you getting?

all those link behave the same, the ddos protection is going on a loop.

Same with guest, new and incognito profile :frowning:

I don’t have any error message

on the cloudfare forum there is a thread that may talk about the same issue.

it talks about a duplicate header and at some point the OP says that it’s fix, but i can’t make a solution out of it.

If that’s talking to someone, still highly interested by a solution, definitely don’t want to go back on an other browser…

Still digging on this and some other people seems to have the same issue, but it’s mostly on serveur site on their own website.
In my case it’s my laptop who can’t access any cloudfare protected website who use the same certificate.

At some point i have tried to remove the certificat, but macos forbids it… but any how chrome who use the same certif manage to clear the ddos challenge.

I have also try to flush my dns cache, it didn’t change anything…

while running the loop and inspecting the page though i can find some error message.

  • status code 503
  • status code 400

tried to run some research on those, but any lead would be a dead end…

looking back on the origine of the bug and what i could gather so far.

the status code 400, according to threads here and there. those cloudfare website won’t accept my request as it may appear the request would come from two different source in a “man in the middle” kind of shady request…
it would make sense as when i lost my internet connection on the origin of the bug, when it came back up it would have “create” a different “requester”, but it wouldn’t explain why the classic solution advise aournd, like clear the cookies/cache, flush the dns, change IP would not solve this…

still in the dark…

Don’t search anymore i’ve found the solution

1 Like

What is the solution? I am too currently stuck trying to get into a website but just stuck on cloudflare screen.

The solution is to enable fingerprinting. Seems cloudflare have added some restriction to ensure it can effectively track user…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.