Brave browser stuck in Cloudflare verification. (It returns a human verification challenge again and again.)

I updated Brave browser a day before yesterday. [Current Brave version: Version 1.45.131 Chromium: 107.0.5304.110 (Official Build) (64-bit)]

After the updating Browser, I couldn’t access to some sites with Cloudflare protection.

I tried to access bellow sites;
1. https://psa.pm
2. https://proxyrarbg.org/torrents.php

When I’m trying to enter to the Website, the Website redirects me to a Cloudflare human verification page as usual. After I’m completing the human verification challenge, the Browser redirects me to complete another human verification… And this process goes as an infinity loop…

I read an official Cloudflare community post about this issue, which is posted before a week. (Above-mentioned community post link: Click here) But I couldn’t find a way to solve the problem. I tried to go to the above websites using Windows 10 in-built Edge web browser, and It worked. And also I cleared cookies and re-tried the Brave, but it didn’t work for me.

Some Screenshots about the problem :arrow_down:


.
.
.

.
.
.

Please help me to solve this problem…! :melting_face: :dotted_line_face: :face_in_clouds: :roll_eyes: :face_with_diagonal_mouth:

Hello everyone.

I read old posts about this problem.

In old posts, the solutions were “Turning off Brave Shields” and “Allowing Fingerprinting.

But they didn’t work for me.

:expressionless: :sleepy:

Please, can anyone help me to solve this issue…?

:red_circle: Problem Solved…

I used a Open Source Free VPN software with custom VPN server support.

I used Fastssh’s V2Ray Singapore AMP server and Problem solved. (Their V2Ray SG OVH 2 server didn’t work for me. And also, I faced the same issue without VPN.)