Brave browser not opening in Linux

The Brave Browser is not opening when activated/clicked. The Brave icon is shown to be running but the browser page does not open.

Every time I tried opening the browser since yesterday.
Note: The chrome browser works fine on the same chrome book with Linux version 11.

Brave Version:
Unable to confirm but updated regularly.

No new apps or software updates done recently.

This started happening today 31 Aug 2022 upon powering up after I had shut it down yesterday. Not an issue prior as I shut it down on a daily basis.

The 9 months old chrome book (ASUS CX5) is my personal laptop and not office/company issued.

I have since uninstalled Brave and reinstalled it. The re-installation appears unsuccessful as the available Brave icon when clicked, runs but the Brave browser is not opening. Also, at the end of the re-installation via the linux terminal, the Brave initial and homepage did not open but the brave icon was made available.

1 Like

Not sure how things work on a Chromebook, but we’ll see if we can figure something out.

What package did you install exactly, and where’d you get it?

After the uninstall, was there still the Brave icon remaining or did it go away?

What happens if you run brave-browser (assuming that’s the correct program name) from the terminal?

1 Like

JimB1,

Awesome, your recommendation to run “brave-browser” worked. The Brave homepage initiated and the browser opens up fine. Thank you very much.

2 Likes

Glad to hear it!

Not sure what’s going on with the icon, but now that you’ve got it running, maybe you can just get rid of the old icon and make a new one with the running instance.

Best of luck.

1 Like

Check the “exec” entry in your .desktop file for Brave to see what it is pointing to. It probably points somewhere else if running brave-browser from terminal works.

2 Likes