Clicking a Link (DDL) Doesn't Prompt to Downloading File

I have failed to download clicking Direct Download LInk in the case of Brave Browser (only). In the case of Chrome and Firefox, those DDLs prompt me to download the files. This happened to me on several occasions. How can I solve this problem? TIA.

I have provided two DDLs as instances-

Final Lab Report
Zoom

@KhokonChandra,
Thank you for reaching out. I have some users experiencing similar issues but they are on macOS. I’m curious about the exact behavior – if you try to download files (for example, downloading Zoom to your machine), is clicking the download link simply unresponsive?

If so, would you mind opening the dev tools console window (Menu --> More tools --> Dev tools --> [Console]), visiting zoom.com, clicking on the download link, then after clicking the link to download fails, sharing the output in the Console window here (a screenshot is probably fine for sake of ease)?

Additionally, I’m curious if trying to download/save files via the context menu (for example, doing an image search, right-clicking on an image and selecting Save as...) also fails to download the image?

Hi @Mattches

I have a similar problem using Brave on macOS (Monterey).

I try to download files (I have tried to download my designs from Canva.com and I have tried to download photos from websites using right click and save as).

In both instances, I get the notification number in the Brave browser icon on the Mac menu about the download, but no files are downloaded. Seems to be stuck in the process.

Here is a screenshot of the console window when Canva.com is open: https://capture.dropbox.com/w2jw0cSQ2qzYA4cW

I also noticed that I can’t upload files any longer to my Wordpress site’s Media Gallery. When I click Select Files, the file window does not open. Here’s a console screenshot: https://capture.dropbox.com/LRkoquc9D6eoKp6A

Not sure if they are related.

Let me know if you need anything else.

Can you both tell me whether or not you’re currently using a setup with multiple monitors when you see this issue?

Hi @Mattches I experienced this on a Macbook Air with no external monitors.

@stela,
Thank you for confirming. I’ll have to do some more digging on this

  1. Try clearing the cache/cookies in brave://settings/clearBrowserData

  2. Also try changing the brave://settings/?search=downloads downloads folder to something different.