Download Menu Closes Quickly

Description of the issue:
When I attempt to save a file (i.e. PDF, AppImage, text, etc.), the Brave download location selection menu appears and then quickly closes after 1 second. Even if I manage to click the “Save” button, the file does not download. The same issue appears across multiple websites.

How can this issue be reproduced?

  1. Right click link
  2. Select “save as”

OR

  1. Click download via the website’s download command

Expected result:
Seeing the Download location selection menu, being able to navigate to desired directory, click the “Save” button, and finding the file at the intended location.

Brave Version( check About Brave):
Version 1.32.115 Chromium: 96.0.4664.93 (Official Build) (64-bit) (https://brave.com/latest/)

Additional Information:
OS: SUSE 15.3

Hello @calle

could you try in the private mode and if it work then the issue either with one of your extension so disable all of them then enable them one by one till you get the one causing the issue
or
the issue with your cache so try to clear it

if that did not help try to create new profile and see if it work fine there

hope that help and have a nice day :slight_smile:

Hi @justsomeone1,

Thank you for the idea. I tried using private mode (without any extensions) and still get the same behavior. Strangely enough, I see the same behavior on my Vivaldi browser (another Chromium-based browser). I also tried uninstalling the brave-browser and brave-keyring packages, removing my user directory for Brave, and reinstalled the aforementioned packages.

The common error I see in my system logs is below.

2022-01-01T20:46:25.794708-05:00 localhost dbus-daemon[30034]: [session uid=1001 pid=30034] Activating via systemd: service name='org.freedesktop.impl.portal.desktop.gtk' unit='xdg-desktop-portal-gtk.service' requested by ':1.81' (uid=1001 pid=31285 comm="/usr/lib/xdg-desktop-portal ")
2022-01-01T20:46:25.800887-05:00 localhost systemd[29983]: Starting Portal service (GTK+/GNOME implementation)...
2022-01-01T20:46:25.875958-05:00 localhost dbus-daemon[30034]: [session uid=1001 pid=30034] Successfully activated service 'org.freedesktop.impl.portal.desktop.gtk'
2022-01-01T20:46:25.876086-05:00 localhost systemd[29983]: Started Portal service (GTK+/GNOME implementation).
2022-01-01T20:46:25.994500-05:00 localhost dbus-daemon[1859]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.449' (uid=1001 pid=1003 comm="/usr/lib/xdg-desktop-portal-gtk ")
2022-01-01T20:46:25.998210-05:00 localhost systemd[1]: Starting Hostname Service...
2022-01-01T20:46:26.248198-05:00 localhost dbus-daemon[1859]: [system] Successfully activated service 'org.freedesktop.hostname1'
2022-01-01T20:46:26.248347-05:00 localhost systemd[1]: Started Hostname Service.
2022-01-01T20:46:26.904678-05:00 localhost systemd[29983]: xdg-desktop-portal-gtk.service: Succeeded.
2022-01-01T20:46:26.905277-05:00 localhost xdg-desktop-por[31285]: Backend call failed: GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

Hello @calle

you very welcome for your main issue

could you go to brave://settings/downloads and make sure to enable Ask where to save each file before downloading

and for the error message sorry i have no idea

and have a nice day :slight_smile:

Hi @justsomeone1 ,

I have Ask where to save each file before downloading on. If I turn off Ask where to save each file before downloading in brave://settings/downloads, then the target file will download to my user’s Downloads directory. So there is some error where the selection menu is utilized.

i just check your version and it’s looks like it’s not the latest version the latest one is

Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit)

try to install it from here to get the latest version

@justsomeone1
Thank you for checking. I tried the beta version which is version Version 1.35.68 Chromium: 97.0.4692.56 (Official Build) beta (64-bit) (https://brave.com/latest/). But I get the same behavior. Even trying to print and save as a pdf has the same behavior when I get to the download location menu.

So there seems to be some sort of bug between Chromium browsers and the GNOME download location menu. Turning off Ask where to save each file before downloading helps with downloads but not the print command often available on web pages.

i use gnome also but with rocky linux (redhat derivative) and do not have this issue

could you try to create a new user account from your os and try brave on that new linux account

This happens with all chromium based browsers and is specific for OpenSuSE Leap 15.3 and 15.2

The bug affects the following browser functions:

  • downloading of files to the local filesystem
  • opening of local files in the browser
  • the ‘save as’ dialog, eg. ‘save as pdf’, which may be used for printing to a file (instead to a printer)

See chrome community

This bug has been reported on opensuse forums

and also a bug report has been filed https://bugzilla.opensuse.org/show_bug.cgi?id=1194102

To solve the issue, downgrade the packages
xdg-desktop-portal-gtk xdg-desktop-portal-gtk-lang

For opensuse leap 15.3, you may type in a terminal

sudo zypper install --oldpackage xdg-desktop-portal-gtk-1.8.0-3.3.1.
sudo zypper install --oldpackage xdg-desktop-portal-gtk-lang-1.8.0-3.3.1.
3 Likes

thanks @commongood for the extra details :slight_smile:

@commongood Thank you for the instructions and the links. Reverting the packages allows me to download with the “save as” dialog menu.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.