"clear passwords" not working

macos
#1

Description of the issue:
After clearing all passwords, they still show up. This started happening after I enabled “sync” from Google Chrome and I noticed the passwords that had sync’d from Google Chome/Cloud were showing up in autofill fields in Brave. I then went to clear them (first from Google Chrome; success., and then from Brave; not working).

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. enable Google Chrome Sync in Google Chrome, and go to settings->Passwords and see that passwords “sync’d”.
  2. open Brave and view passwords in brave://settings/passwords
  3. at this point you can see that they’re sharing/sync’ing the same pwd data/information. Exit the browsers in an attempt to ensure whatever data source they’re sharing has connections severed.
  4. Open Chrome and clear all the passwords via Settings->Advanced->Clear Browsing Data and confirm they’re gone in chrome://settings/passwords. Exit Chrome.
  5. Open Brave and clear all the passwords via Settings->Advanced->Clear Browsing Data and confirm they’re gone in brave://settings/passwords.
  6. View Brave’s passwords via brave://settings/passwords and notice they’re still there (see attachments). Go back to Settings->Advanced->Clear Browsing Data and notice that the passwords section suggests there are “none” passwords to clear.

clearly something’s amiss.

Actual Result (gifs and screenshots are welcome!):
passwords are still in Brave even after clearing them all.

Expected result:
no passwords exist in Brave anymore.

Reproduces how often:
everytime.

Operating System and Brave Version(See the About Brave page in the main menu):
OSX - 10.14.4
Brave - Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit)
Chrome - Version 73.0.3683.103 (Official Build) (64-bit)

Additional Information:

#2

@jvaleski,
Thanks for posting. Im looking into this on my end but first I’d like to point out that – unless something really broke – Brave and Chrome cannot Sync data between one another. The only way you can get data from one to the other is by way of import (Menu --> Bookmarks --> Import bookmarks and settings). Additionally, Sync only syncs bookmark data in Brave at this time.

As for the issue concerning Brave not clearing those passwords, I’m unable to reproduce that as well. Testing on my end, using the Clear Browsing data feature with Passwords box checked clears passwords as expected:

Can you try this with a separate profile? Use the “people” icon next to the main menu to create a new browser profile. On that profile, sign into some site you have an account with and perform the same steps shown in my recording above.

Do you see the same behavior?

#3

ok. something’s no bueno here. new profile, save pwd, clear all pwds, did the right thing. all good there.

however, w/ my main profile, there is no way those passwords could’ve gotten into Brave without sync’ing w/ my Google account “somehow.” I haven’t visited 2/3s of those sites ever with Brave, let alone logged into them. they appeared after I logged out of Chrome sync’ing, and logged back in (for other reasons I was messing w/ some stuff on/in Chrome). that process sync’d pwds across bound Chrome instances across my devices, and somehow dumped them into Brave. while that certainly wasn’t expected, the bigger issue at the moment for me personally is my inability to delete them.

is there somewhere I can be poking around in directory/file structure on OSX that could be useful in debugging this, and also allow me to manually delete the data by hand from a directory?

#4

@jvaleski,
Definitely something afoot – I’ll have to dig into this further. Appreciate your patience and please bump this thread if I haven’t replied by end of day.

#5

@jvaleski,
Did you import your Chrome data to Brave at any point after installing?

#6

I might have but I can’t say with 100% certainty. Possible to find out? I’m pretty sure I did.

#7

@jvaleski,
This might be part of it but it’s hard to say. If you’re okay with it, I would recommend doing a full wipe of your Brave data and reinstalling. I know that sounds like a whole thing but there’s a good chance it will resolve the issue.

  1. Uninstall on macOS by
  2. Trashing the .app in the Applications folder
  3. Removing Brave icon from dock
  4. Most importantly, delete the profile data located in Library/"Application Storage"/BraveSoftware/Brave-Browser/.
    Note that this will remove any saved sessions, bookmarks etc you have there so ensure that you export bookmarks and/or backup any other data you’d like to keep.

Download/reinstall Brave. If you launch and those passwords are still showing up please let me know asap.

#9

jessicasmith’s comment looks like spam to me.?

anyway, of course, your suggestions fixed the issue. I will note I had a Brave Browser Dev folder in BraveSoftware too, so my system’s been bouncing around various installs over the past several months. I guess we can chalk this up to some odd config/wires getting crossed and they’re uncrossed now. Thanks!

1 Like
#10

same with me needs to be fixed soon!!!

#11

i removed all extensions (tried several and none would clean) and clear history worked???