Clean install - Brave crashes within seconds of launching

windows

#1

Description of the issue:
Clean install of Brave - after installation it launches and I’m able to go through the startup wizard but as soon as that completes the browser crashes

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Download and install Brave 64bit for Windows
  2. Click through startup wizard
  3. Home page loads and browser instantly crashes

Actual Result (gifs and screenshots are welcome!):
After first run Brave crashes within about 1 second of launching.

Expected result:
Brave launches and I am able to view (default) home page

Reproduces how often:
Every time

Brave Version(about:brave):
Not able to use about:brave but Windows reports it’s 71.0.58.21
Have also tried Beta - Kaspersky blocks this from installing (see other post) but if I exit Kaspersky and install the Beta it performs identically

Reproducible on current live release (yes/no):
Yes

Additional Information:
Windows 10 version 1809 build 17763.253
Because the browser crashes more or less instantly I have not been able to capture any other information, but happy to do so if there are logs or a way to enable debugging. I have tried exiting Kaspersky while installing and running Brave but it has not made a difference.
I can install Brave on a different Windows 10 PC just not this one, I would prefer not to have to perform a clean Windows install if there is a way to troubleshoot this.
Many thanks

Update: At the exact time of the crash the System log in Event Viewer reports the following:

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 25/01/2019 14:21:06
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: [redacted]
Computer: [redacted]
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user [redacted]\[redacted] SID ([redacted]) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.


#2

Thank you for your detailed report @preacher65. I saw your post about Kaspersky as well, thanks for letting us know about that one too. I’ve already reached out to them about false positives still showing up.

Have you tried installing Brave (any) after deactivating Kaspersky?


#3

Thanks - yes the two issues seem to be entirely separate. Kaspersky only affects the Beta installer, plus I have installed the Release version of Brave on my laptop which also has Kaspersky.

I have exited Kaspersky and tried uninstalling and reinstalling Brave on the PC.

The only thing I can think of in relation to Kaspersky on the PC is that I did try installing Brave (release branch) back in December, had issues with Kaspersky blocking the installer then. I tried exiting Kaspersky and reinstalling but Brave behaved the same.

It’s possible that despite uninstalling and reinstalling Brave since then, something is left over from that original (failed) installation that was corrupted during the initial install.

I’m going to look into that DCOM error shortly.


#4

@preacher65, great information, thank you.
When you uninstalled Brave (Release) on your machine, did you also elect to remove the associated browsing data along with it? This generally appears in the form of a pop-up notification when using the standard Windows installer:


#5

I tried to, but the window with that option does not stay open long enough for me to tick the box. The uninstaller immediately starts without any user input, which is really odd.

One at least one attempt I did manually delete the appdata\local\BraveSoftware folder after unnistalling, so that it could be recreated on the next installation attempt.


#6

Excellent, that’s exactly what I was wondering about.
Strange that this is happening to a Win10 system. For the release build, you might want to try disabling hardware acceleration. Since the browser crashes on launch, you’ll have to edit the target path with the --disable-gpu flag. See my solution here for steps to set this flag:


#7

Thanks, but sadly that doesn’t cure it.

This is how Brave opens but it closes after 1-3 seconds even with the --disable-gpu switch.

Edit: Tried a non-admin installation into the user profile and same thing.

I think I did get the beta running at one point - it didn’t crash straight away - but when I uninstalled it and reinstalled the release version it still crashed. Have been unable to reproduce that since…

Also it no longer asks if I want to delete browsing data when I uninstall. The dialogue simply doesn’t appear.

(NB. Kaspersky has been exited prior to trying any and all of this.)

What I would really like to try is to uninstall and then remove any and all remaining traces from the filesystem and registry. Are there any instructions for removing things left behind by uninstall?

Also possibly going to try a re-install of Windows 10 1809 by doing an in-place upgrade to see if that repairs any DCOM errors, as I’ve not been able to resolve all of them. sfc /scannow has not reported any errors.


#8

Brave still crashes after a re-install of 1809 (in-place upgrade).

Thanks for the help so far, will see if you have any more suggestions but may try a clean install of Windows over the weekend.


#9

Just a quick update - installed a clean version of Windows on a spare ssd, needless to say Brave installed without a glitch. I’ll transfer everything over to the new drive, as it’s clearly a problem with this Windows instance rather than Brave itself, and Windows probably needed refreshing anyway.

I seem to recall having problems with Kaspersky the first time I tried to install back in December, so it could be that a broken installation from then hasn’t been entirely removed and a corrupted file somewhere is causing problems. (It would be helpful if there were manual uninstall instructions somewhere.)

Anyway, problem solved and thanks for the support. Very impressed to have got such quick responses for support with free software! Looking forward to trying Brave out as my main Chromium-based browser. :slight_smile:


#10

Hello preacher65, reading thru your helpful post I noticed the DCOM issue & just thought I’d share, it may save you time you’d prefer to allocate to something with a more beneficial outcome [DCOM, The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID] is a known/very old Microsoft problem they’ve never addressed. Probably 18 mths ago I started to try & resolve, using all sources, all solutions did not resolve, I finally accepted the considered advice from trusted 10Forums experts/posters like Brink/EdTittle. If you’re interested I’ll compile a list of the links & post back, please let me know, cheers🙂