Major CPU Spikes on RBC Canada Online Banking


Description of the issue: Within the last week - Brave becomes unresponsive logging into RBC Canada Online banking site. Once in - the browser takes 3-4 seconds to allow links to be clicked on. Also noticed a 15% CPU spike in one of the brave.exe instances everytime a page is (finally) opened OR a link is clicked on.

Exact URL of the website in question: https://www1.royalbank.com/cgi-bin/rbaccess/rbcgi3m01?F6=1&F7=IB&F21=IB&F22=IB&REQUEST=ClientSignin&LANGUAGE=ENGLISH

Did the issue present with default Shields settings? (yes/no) - YES

Does the site function as expected when Shields are turned off? NO

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): Unknown

Does the site work as expected when using Chrome?: Yes. Works perfectly in Edge Chromium as well

Brave version (check About Brave): 1.7.92

Screencaps

2020-04-20_13-33-21

Should also add that previous versions of Brave - from maybe 10-12 days ago ran like lightning on this site? Not sure what has changed - but this is not a good look for Brave right now.

UPDATE: Still happening on v1.7.98.

UPDATE 2: (05-02-2020) This is now happening with a Citibank site associated with Home Depot Canada. The CPU locks at 14% whether shields are on or not.

Works fine in the latest version of MS Edge for Business (81.0.416.68)

Thanks!

Sonic.

Update II

After enabling this setting:

brave://flags/#brave-adblock-cosmetic-filtering

It seemed to work only that one time. Brave is back chewing up CPU and freezing while loading the various pages. A good 5 second delay on each page now. Here’s a snap from the Brave Task Manager…

Sonic

I had a similar problem, not with RBC but TD WebBroker. I could not really even connect to their site at all. I have to switch to another browser to log into their site.

Mike

As did I. Installed the latest version on MS Edge for Business and it works perfectly.

This is of course worrisome to the Brave cause. I get that they want to be the best when it comes privacy, ad blocking etc. But the RBC has no ads and nothing really untoward to block.

Seems the browser itself is creating hassle by doing too much - which is really not necessary.

What is really annoying is I turn all the “shields” and stuff OFF in Brave and it still does not work? What’s up with that?

Sonic.

Ok - now I am getting close to switching this out.

Brave does not work on Turbotax Canada (intuit.ca) now either. I just spent a painful 10 minutes trying to update my Intuit acct. Finally gave up and switched over to MS Edge for Business.

What is going guys? You are killing this browser with these latest versions.

2020-05-05_10-42-10

This is with or without Shields.

SOnic

I’m still having this issue with TD WebBroker and with Coast Capital Savings. Some days it’s a 30 to 60 second “wait” (“do you want to kill this page or wait for it?”) before it resolves. On Coast Capital, subsequent page loads can take up to 30 to 60 seconds, depending on the page. I have seemed to notice that the status bar typically states it’s waiting for another domain (a CDN or auth service…). Other browsers are fine for the same sites.

(Also – Shields are down for both).
(Will reply with full issue information after I’m done struggling through my banking :wink:

Same problems continue with RBC. Have switched to Edge for Business now to do banking runs. It is very fast and does not have any of the baggage described in this thread.

If these guys are going to play ball with the rest of the browser gang - they need to get this fixed. Sadly Brave was just fine about 6 weeks ago with RBC etc. Whatever they have “added” (which of course no one asked for) is now causing me to seriously rethink this product.

The more I read about the BAT and crypto wallets, extensions I cannot turn off etc. - the more I am pulling away from Brave. I am beginning to wonder if this browser is really as privacy focused as they are trying to portray.

Sonic.

For me, the browser was also working fine about 6 weeks ago, which gives me some hope that it’s an identifiable problem and fix. I often feel the same frustration and share some of the same questions, but then I remember that this is a bunch of folks trying hard for the right reasons, generally speaking, and has (so far) helped me tolerate some of this pain. I’m going to flip browsers for banking now as well, and cross my fingers that this gets addressed.

With that said, @Brave Devs – here’s the more extensive bug report:

Description of the issue:

Since around mid-april (can’t remember exactly), banking site login pages and some internal pages are unresponsive for times ranging from a few seconds to a few minutes. In particular, TD Web Broker, Coast Capital Savings Personal Banking and MBNA Canada (which is also TD).

In all cases, the pages seem to be “waiting for” calls from other domains.
In all cases, pages do not exhibit this behaviour in Safari or Chrome.

Exact URL of the websites in question:
Coast Capital Savings Personal Banking “Transfer Funds” page:
https://banking.coastcapitalsavings.com/Security/Transactions/Transactions.aspx?trxid=TRXC0121796

Coast Capital Savings login page:
https://banking.coastcapitalsavings.com/LogIn.aspx

TD Webbroker Login Page:
https://wb.authentication.td.com/uap-ui/index.html?consumer=webbroker&locale=en_CA#/index

MBNA Canada Login page:
https://authentication.mbna.ca/uap-ui/index.html?consumer=msec&locale=en_CA#/login/login/mbna/login/mbna/mbna-login

Did the issue present with default Shields settings? (yes/no) - YES

Does the site function as expected when Shields are turned off? NO

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): Unknown

Does the site work as expected when using Chrome?: Yes.

Brave version (check About Brave): 1.9.72 (and a previous 1.8.xx version)

I wish them nothing but success as well - but we cannot have a browser failing on something as critical as online banking?

I totally get that they want to be the choice for ultra stealth privacy mode - but seems like something they are doing is taking this way too far.

And the lack of ANY acknowledgement from the DEVS is a huge red flag. If they are too busy working on Crypto Wallets or their rewards program to address these rote basics (Like online banking - espeically in a pandemic) then what does that say about their overall plan?

If they want Brave to succeed and have the users stay with it - there is no room for problems like this to continue for weeks and weeks. I am as patient as the next guy but there comes a point where I need to do my thing with a tool that works.

Brave is hanging on by a thread here…

Sonic.

I appreciate your thoughts, Sonic – I hadn’t put together that none of the devs had even responded to your and we’re coming on two months. That’s frustrating, and certainly dampens my expectations.

Update: 2020-06-13

The Brave update subsequent to yesterday’s came with some improved performance on this problem for the TD WebBroker website. But the most recent update has made things worse again, and has caused Brave to go back to being unusable on all the sites I’ve mentioned above (including TD WebBroker).

Version 1.9.80 Chromium: 81.0.4044.138 (Official Build) (64-bit)

ANY BRAVE DEVS OUT THERE? – Respectfully: can we get a ping on this post, please? Banking sites have been failing in Brave for coming on 2 months. It would be nice to just know this is on your radar. Thanks!

I can take a look. Debugging financial sites can hard, for privacy reasons.

Also some of those sites are using fingerprinting and portscanning, looking at td.com, not sure about the others. Which impact the enduser.

1 Like

Okay, This is related to me blocking the fingerprinting / port scanning scripts being used on various sites. From the recent article on https://www.bleepingcomputer.com/news/security/ublock-origin-ad-blocker-now-blocks-port-scans-on-most-sites/

TD Webbroker: https://github.com/easylist/easylist/commit/2855dab

MBNZ Canada: https://github.com/easylist/easylist/commit/7f77487

Sorry I couldn’t replicate the issue https://banking.coastcapitalsavings.com/ Would need to look into it futher/troubleshoot with a customer of this bank.

These 2 commits should improve the performance of the sites, let me know if it causes major issues. Give it 24-48hrs, and the update for these 2 domains will roll out.

1 Like

Thanks for taking a look @fanboynz – I’ll keep checking and let you know in a few days. Cheers!
C

Hi @fanboynz

The TD Direct Investing is slightly better on occasion(Sometimes, I only have to wait 20-30s for the login to become active, but sometimes it never does). When it hangs, the status bar in Brave reads: “waiting for tmx.td.com

The MBNA site I can work around - hitting “X” (stop loading) on the browser allows the login box to work, and progressing from there is no problem.

The Coast Capital Savings still requires “minutes” for the login box to become active (if it ever does). And the “transfer funds” pages inside take “minutes” to become active on each page load. I know you didn’t troubleshoot that site, but just providing the info. On both the login and internal pages, the Brave status bar reads: “waiting for cdn.coastcapitalsavings.com

Brave Version: Version 1.10.93 Chromium: 83.0.4103.106 (Official Build) (64-bit)

For now I’m going start using a different browser for banking, but I’ll keep trying with Brave if new updates come. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.