Certain websites won't load

I first noticed this problem with the Coronavirus Update website, https://www.worldometers.info/coronavirus/, but now it’s happening with some other sites. The problem is that the site never fully loads, and I am unable to scroll down; it just is stuck. I am able to close out of it, though it takes a few seconds to close. AND, when I load the site from incognito mode, it loads fine. This problem just started yesterday. I tried to fix it by uninstalling and reinstalling Brave, but that didn’t change anything. This never happened before yesterday.

Also, I have no idea if this is in any way related, but another problem I’m having is that Brave no longer saves a list of passwords. It saves passwords covertly, but it won’t show the list to me.

Thanks, any help would be greatly appreciated!

Jeff Melton

Description of the issue:

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

Trying to reproduce this. Can you try in private mode? Does shields affect the endless loading?

Yes, I tried it in private/incognito mode, and the problem doesn’t happen there. It also doesn’t happen if I try loading the site from another profile. It’s only in the one specific profile that I use most of the time that it happens. Of course, I can/do work around it by just putting everything I need into a different profile and using that one, but I’d like to figure out what happened and how it could be fixed.

Turning off shields doesn’t change anything.