Canva Won't Load: Error Code 4 "Aw, Snap!"

Anytime I try to load Canva at all, even after clearing all cookies, and trying on a private browser, I get an “error code 4”, and it won’t load.

How can this issue be reproduced?

  1. I have many Brave profiles, each of them return the same error.
  2. This happens even on Private browser.
  3. Also happens on Private + Tor… it loads for a second and then “Aw Snap!”
  4. I’ve already cleared my total history and restarted several times.
  5. Already disabled all my addons one by one and tried reloading… nothing.

My expected result is that it will load just fine the way it always does. Started happening yesterday afternoon with no explanation.

v1.50.121 (Apr 19, 2023)

PS: It works on Firefox.

Do you also have Chrome that you can try it on? Asking as Firefox is a completely different core. So it would be helpful to test to see if it’s a Chromium issue.

Other things to try:

  • Does disabling Shields change anything?

  • Can you create a new profile within your browser and see if it makes a difference? I’m assuming won’t resolve based on the other details you provided, but wanting to make sure. (just use this as a test profile, then can delete it. Try not to add anything to it, just use it as it comes at first)

  • Could you perhaps try getting Brave Beta or Brave Nightly and see if either version works?

Yeah, we are having the same problem on Brave Browser Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit) on PCLinuxOS at our public library when trying to go to Canva ( with & without https.

We have tried:

Everything on the help page called How do I fix page crashes and other page loading errors?, and:

Clearing the cache, deleting all Canva cookies, incognito mode, new profile, guest profile, turning off secure DNS & turning off forcing HTTPS, disabling fingerprinting protection, disabling third party cookie blocking, disabling shields, we tried it on two different computers with two different users, and more.

Nothing worked so far.

This problem does not happen on Mozilla Firefox, Google Chrome, Microsoft Edge.

Only Brave has this problem, this is very strange.

To make things even more strange, when you disable Shields and click the Report Broken Site option, it does not work, so I can not even use the report broken site option for the Canva website; that is how bugged it is.

Hopefully you can fix this, because they need this for work.

Thank you,
— John Jr

@goodjohnjr just have to ask as different username, are you and @djzee two completely different people having the same issue or both of you are using same devices and you just answered separately?

I’m on Windows rather than Linux, but when going to the same website, I don’t get the error you shared.

If I was judging just based on the screenshot you shared, I would notice that you had extensions running and it’s always the #1 thing to cause problems. But if take you at your word about new profile, private window, guest mode, etc and it still had issues, it should rule extensions out as an issue (so long as you didn’t do anything to load extensions in all of those! lol)

Is this the only place you’re trying to access? Also, is it your device? Guess what I’m sitting here wondering is if there’s something screwy in firewall, network rules, or something else going on that might be creating conflict. A lot of what we were looking at earlier were things inside the browser, but now I’m kind of wondering if it’s something on the device itself or the internet network you’re using. Especially, you using a VPN or a proxy?

Anyway, last question: If you have Dev Tools open (which you can do with F12), are you getting any errors listed under Console? I highly doubt we’re going to get anything there, but maybe will catch something that can provide a hint.

@fanboynz would you happen to have any ideas?

Will be the malware bytes extension I suspect. (or Malwarebytes “Web protection” setting)

Hello @Saoiray,

We are two different people, I am not sure who they are, I posted here since someone else seems to be having the same issue; I am not sure what operating system they are on, perhaps they are on Linux too.

Yeah, I have the web extensions Read Aloud, LanguageTool, and Malwarebytes Browser Guard on my computer; but these are not installed on the computer that the issue was first noticed on.

I tested it on my computer to see if the same thing was happening, and it was; so it happens with & without extensions.

I even disabled extensions and tried it again without luck.

The report Broken Site option does not work on that page from Shields or from the Menu, it works on other websites, but not the broken Canva page; which is weird, but could give you some clues.

So far I have only tried it on two different work computers for someone else and myself.

We are not using a VPN or proxy that I know of, but I could be wrong.

Here is what I get with Dev Tools:

Thank you,

  • John Jr

Thanks for responding @fanboynz , normally I would think that too, but it was reported by someone not using any extensions; I happen to have the same problem with extensions and with them disabled.

I do use the Malwarebytes Browser Guard extension on Chrome, Firefox, and Edge; and Canva still works on those web browsers.

So this is weird, what is weirder is how even the Brave report Broken Site option does not work, so I can not report that broken site within Brave itself.

The report broken site does work on other websites, just not the broken Canva page.

You’re on Elements part of it. Would want to look at Console as that’s where it would show errors, if any. That said, I’m not expecting much but it was just throwing out a line in case.

Just a FYI, it’s preferred anyone creates their own topic. Part of the reason why is information gets confused. But not only that, attention essentially gets “stolen” in many cases, where more replies go to other people and whoever opened the topic can end up unintentionally ignored. Well, assuming they return to their topic.

Hello @goodjohnjr @djzee

this error happen only when my installations get currpted so to isolate that from the cause stack

could you use any linux live cd/usb and boot your computer from it then install

brave from those command line based on your distru

and could report if you tried the following since :

  1. create new windows/linux user account (nor brave profile) and use brave on that new account and see if it work fine or not

could you also report which os you use both of you and which distro in case of linux and how you installed brave in case of linux using the command line or snap or what?

hope that help and have a nice day :slight_smile:

1 Like

Hello @Saoiray,

It will not let us click on the Console, it is all greyed out, even if we click on it; I had our System Admin try it, and he got the same thing.

Thank you for letting me know, I am new here at the Brave Forums, and different forums have different rules; some want you to keep the same topic all in one thread instead of creating a new one, but I can understand some of the reasons of starting a new thread.

Our System Admin said that he installed Brave from terminal using the official PCLinuxOS repositories, he suspects that something is possibly bugged in one of the libraries for that version.

Our System Admin tried a virtual machine running Devuan Linux, he installed Brave in terminal from the official Brave repositories, and it worked; but it had a slightly newer version than the version available at the PCLinuxOS repositories.

Hopefully the next version of Brave from the PCLinuxOS repositories will not be bugged.

Perhaps someone from Brave could take a look at the PCLinuxOS repositories to see if you notice anything unusual?

Thank you,

  • John Jr
1 Like

Hello @justsomeone1,

Thank you for sharing that.

This is what our System Admin tried so far:

Our System Admin said that he installed Brave from terminal using the official PCLinuxOS repositories, he suspects that something is possibly bugged in one of the libraries for that version.

Our System Admin tried a virtual machine running Devuan Linux, he installed Brave in terminal from the official Brave repositories, and it worked; but it had a slightly newer version than the version available at the PCLinuxOS repositories.

Hello @goodjohnjr

you very welcome

but i still have some questions:

  1. what brave version you have on PCLinuxOS could not you install brave there from the brave repo from PCLinuxOS help i notice it can install rpm package so you can use the brave repo for fedora

  2. the brave version you installed on Devuan is v1.50.125 am i right?

  3. did you tried to create new user account on PCLinuxOS and check if it work fine or not?

  4. could you start brave using the following command on that comment

hope that help and have a nice day :slight_smile:

Hello, @justsomeone1, thank you for responding.

  1. Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit).
    I forgot why our System Admin said that he is only using the PCLinuxOS depositories, there is a reason, I think that he said that he could not do the official Brave repo for PCLinuxOS, possibly something to do with how our system is configured; I will have to ask him the reason.

  2. Yep, and that version worked without a problem on Canva.

  3. I forgot to mention, that he did open PCLinuxOS in a virtual machine with another (third) user account, and he still had the same problem with
    Version 1.50.121 Chromium: 112.0.5615.138 (Official Build) (64-bit)

  4. I ran that command, Brave started, I tried Canva, and it still failed.

Hello @goodjohnjr

you welcome all i can see is :

  1. brave need to reinstalled


  1. the old brave version has bug that the latest version fixed it

  2. issue with the brave from the pclinux repo (which should be fixed by pclinux)

hope the admin find some of what i said helpful and have a nice day :slight_smile:

Hello @justsomeone1,

It is possibly two and / or three, he is still waiting on PCLinuxOS to release the current version, we shall see what happens.

I found another website impacted by this finally, my blog:

That makes me wonder if Canva is also based on WordPress.

Anyway, thank you for the help, and I will try to remember to let you know if the next version on PCLinuxOS has this issue or not; and if I remember, I will ask our System Admin why he is not using the Brave repo instead of the PCLinuxOS repo, and I will let you know what he says.

Have a good weekend,

  • John Jr
1 Like

Hello @goodjohnjr

i did not used canva before but your link work fine from my side using linux Rocky 9.1 (redhat 9.1 alternative distro) with brave version v1.50.125 and work fine

thanks and you too

Thanks, @justsomeone1, I am curious, have you tried Brave Version 1.50.121 on Linux, to see if you get the same result as us with that version, since we know Version 1.50.125 works?

you welcome @goodjohnjr no i did not and there are a problem when i tried to install that version on a fedora live cd/usb that brave did not even start cause the chrome part of brave had bug the prevent to start you can read the details of the issue here

so for that particular version i can not help sorry

1 Like

Thank you, @justsomeone1 & @Saoiray, our System Admin updated Brave Browser for PCLinuxOS after the update was finally available, and this bug is not present in version 1.50.125.

Have a nice day. :+1: