Can't verify wallet on Windows or Android

Description of the issue:

I’m verified on Uphold and my wallet’s connected.

However, on Brave for Windows, it’s telling me I need to verify my wallet on the Brave rewards page. However, when I click either link for verification, the links are non-functional – I click them and literally nothing happens.

On Android, I also have a “verify wallet” button. When I tap that, Brave just crashes, revealing my home screen again.

So in short: my Uphold wallet is verified and connected to Brave on Uphold’s website, but the browser on Android and Windows both don’t recognize that it’s verified. And when I try to verify, I either get nothing or a crash.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to brave://rewards/
  2. Click either “Verify wallet” link (see results in mp4 below)

For Android:

Actual Result (gifs and screenshots are welcome!):

Here’s a screenshot from my Uphold account on uphold’s website as proof that Uphold is verfied and it thinks it’s connected to Brave: (

Here’s nothing happening when I click either verify link on Windows:

Here’s a screenshot of right before Brave crashes on Android if I tap the “verify wallet” button you see here:

Expected result:
I’m taken to get my wallet verified and/or the browser doesn’t crash.

Reproduces how often:
Repeatable/all the time.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 Pro 2004 running Brave Version 1.19.92

Android 9 running Brave Version 11.19.88

Any insights on these crashes would be greatly appreciated.

Might be because the servers are currently down / in maintenance

This has been a long-standing issue on the order of months, so I don’t think that’s it. Thanks for the reply, though.

Does it work now? It worked for me and my wallet is verified now.

No – same issue with desktop as described in the OP.

Looks like the “Verify Wallet” link on Mobile that I put in the OP is gone. But the funds are not showing up on Uphold even though I’m a verified member and Brave shows up as a connected app:

That is because the payout is on hold currently. Apparently on March 5th they will process the first payments.

Thanks again. I’m afraid that still doesn’t explain why I can’t click on anything in the desktop version as shown in the OP, though.

I couldn’t click on anything too.
Now it works, it might be a bug.

+1 on this, having the same issue on my desktop.

+1 here, exact same issue as OP. Uphold says it’s connected to Brave, but Brave Rewards wants me to verify, and the buttons do nothing. Click, click. Nothing. I’m afraid to do a clean uninstall/reinstall of Brave for fear of losing my rewards (~40 BAT).

Any help here? This is annoying.

I have the same issue & I’ve noticed many posts that communicate this same issue (I’ve posted as well).

On the desktop version, only the settings & view monthly statement buttons/links actually work for me.

Is your Uphold registered in NY by any chance? My gut feeling’s that that could be the issue.

Yep, it actually is registered in NY. I posted this thinking that Uphold was okay in NY now, but I guess it still hasn’t been approved?

They don’t have a license in NY yet (& I don’t see any progress) so you’ll probably have to wait until the Gemini integration. Regardless, buttons shouldn’t just stop working without any guidance.

Ah yes… I am in NY. That’s probably why. I know Uphold wouldn’t let me register for the longest time because of this. But suddenly last month I was able to finally finish the registration with Uphold. I had thought that meant I could finally use the BAT Wallet. Oy… guess I’ll have to wait for Gemini. Thanks sQUansEA

Confirmed … I relocated and everything worked as soon as I updated my address with Uphold. So yeah, unless you’re relocating anytime soon, wait for the Gemini integration.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.