Can't use Posteo webmail on Brave

So its now working? No issues at all? (with Sheilds enabled?)

Sorry if you misinterpret my post. I have shield disabled all the time. I have left Brave loading the webmail for couple of minutes and somehow it loaded the emails. Later I tried it again and I didn’t load them again. Someone already said that Brave sometimes loads the emails, for me 2 out of 50 times after 5-10 minutes… So in conclusion: Posteo webmail doesn’t load more than 1 email in Brave.

Okay, I’m attempting to reach out via twitter to see if I can get a dummy account

Hi, everyone I use Brave since a coupple of days and I encountered the same Issue with posteo.de Webinterface. But I found out, that if i turn off Brave shiels (site only) and reload the hole page. it would work.

So I can login, first I see the first mail in my inbox, than I open it, then reload the Page and I see the whole Inbox.

I would be happy if it would work as normal.

Ich use Windows 10 Pro

When the issue occurs; Could you paste the sheilds (trackers) being listed on the site?

By now, shields listed no blocked trackers etc.

Does allowing cookies and/or all-device recognition and/or disabling upgrading https help?

Possibly one of those is causing it?

I tried every setting. Disabled everyting and mixed up but it’s the same. Sometimes it loads but upon refresh its the same. I couldnt reproduce loading of inbox.

It’ll come down to, if its Sheilds=On issue. it’ll be one of the settings. Does turning off sheilds definitely fixes it?

In my case not at all. It´s looks like something other triggers this problem. Now with shields on, i do the same as with shields off. Ich klick on the first mal in the inbox and thean reload the whole page, then it shows all Mails.

Page reload doesn’t work for me. I’ve disabled shields and all extensions except Lastpass still with the same problem.

For anyone still in this thread,
Posteo support were kind enough to give us a temp login email to test with Brave.

On my end, everything seems to work without issue:

  • Initially, I got the “infinite loading wheel” displayed.
  • Checking dev tools, I noticed a cross-site frame was being blocked – I changed Device Recognition in the Shields panel to Allow all which resolved the issue
  • Further, I then changed Device recognition back to Block 3p, site continued to work without issue.
  • I’m still running some tests but it seems as though I’m able to access my account without issue:

I’m afraid you’ll have to walk me through your changes. I can’t find any of the settings you reference.

1 Like

Doesn’t work for me. Please write how-to step by step. Maybe inbox was too small for sample?

@fstjohn @justaq,
I’m going to do some additional testing with a larger inbox size (first ~50, then ~100+) and see if I can still use the client as intended. If so, I’ll then return with a short step-by-step recording should it still be necessary.

Appreciate your patience, everyone.

Alright so I forwarded ~50 emails to the account and proceeded to login. As before, the inbox loaded the first 3 messages or so and the spinning loading icon kept chugging away. After waiting for a moment to see if it sorted itself out, I went ahead and set my Device Recognition setting in the Shields panel to Allow all. The page refreshed but did not resolve the issue.

However, after restoring the Device recognition option to it’s original state, the page refreshed and all emails in the inbox loaded and the “loading” symbol disappeared. Apologies for the “slow” video - trying out new recording software and am still learning hotkeys :slight_smile:

To be honest, I’m not entirely sure why this is behaving this way. I’m going to go back, clear the inbox and do another bulk forward to the account and retest. In the meantime, can anyone here try changing their Device Recognition setting in Shields to Allow all and then back to Block 3p and see if it has any effect?

I dont think Device Recognition is way to go. For me I have to switch All-3rd party multiple times to load. But I think that is coincidence. Upon logging out and in I have to do whole switching multiple times again with variable success. Dont think its related too much…

@justaq,
Thanks for testing.
While I still get the same issue on Release build, both Brave Nightly and Developer builds do not seem to have the same behavior:
posteonightly

This may be due to the new Shields Ad-block rust implementation making it’s way down the development pipeline. Since this does not occur in Nightly/dev, it’s likely that the fix for it will be pushed along with future updates. I will still do some additional testing to see if we can find a workaround in the interim, but hopefully it helps to know that a fix does exist and will probably hit in the next major update.

I have just tested Brave Beta build and it loads the inbox! Thanks @Mattches for bringing the idea forth

2 Likes

I had the same issue, after trying with the Beta today it works!

2 Likes