Always allow website.domain.net to open links of this type in the associated app does not work*


Always allow website.domain.net to open links of this type in the associated app does not work
How can this issue be reproduced?

  1. Set Microsoft Outlook as the default email on the Mail app.
  2. Click on any email address or mailto link on Brave V1.26.74 on website.domain.net
  3. Check the always allow box and Click “Open Microsoft Outlook.app”
  4. Reload the webpage or quit and open the webpage website.domain.net, and then click on the email address or mailto link. The same prompt “Open Microsoft Outlook.app” appears again.

Brave should have opened outlook without the prompt:

**Brave Version( check About Brave): V1.26.74

Additional Information:

1 Like

@voldemort,
Thank you for reaching out to us.
It’s funny because another user yesterday reported having the exact opposite problem – the check box cannot be undone.

Let me reach out to the team and see if anyone else can reproduce this – it seems to work as intended on my end.

That is funny.

I even tried creating a test HTML file:

Test Web Page!

Testing outlook on brave

Send Email

Opened it using Brave
file:///Users/voldemort/Downloads/test.html

Clicked the send email mailto link
Clicked always allow and opened outlook
Clicked the link again. Same problem.

1 Like

@voldemort,
Thank you for the additional test and info. I triple checking but it doesn’t look like this particular issue is logged right now so I’ll likely file one here shortly. Will reply here with the link to the issue once opened.

@voldemort,
I’m curious – does this same behavior occur for you with other file types? Or is it specifically mailto links?

@Mattches Zoom/WebEx links work fine. The browser remembers the setting and opens the app right away without a prompt. Haven’t tested others.

1 Like

Thank you for confirming.

@Mattches I was wondering if you were able to log this issue?

@voldemort,
I sure didn’t – that’s my bad, got distracted by a million other things. I went ahead and opened one just now, sorry for the late reply:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.