Postbox uses Chrome as the default Browser but not Brave

I need a solution to be able to use Brave as my default browser when using Postbox email client. It won’t open the clicked link in Brave, although it works fine with Chrome as the default browser.

Need help. Thank you.

Hi @stub,
What OS are you on? Can you confirm if Brave is set as your default browser within the OS settings?

Windows 10. Yes Brave is set as my default browser. With this setup clicking on a link does nothing. Change my default browser to Chrome or Firefox, clicking on a link, opens the link.

On my end, using Windows 10, I was able to download, install and setup Postbox, link it to my gmail account, then open links from the Windows Postbox mail client in Brave. I have Brave set as my default browser, and Postbox set as my default mail client (but it turns out that I don’t even need to have Postbox set as my default mail client).

Can you confirm that your Default apps Settings on Windows looks something like this?

1 Like

Yes I’m using Postbox as my email client and Brave as my browser client, just like you. But Brave is not opened when I click on a link in a message, whereas if I use either Chrome or Firefox as my default browser, when I click on the link, the browser loads, But not when Brave is my default browser.

For example. If I try to click on the Visit Topic link in your post, nothing happens when Brave is my Default Browser. Change my Default Browser to Chrome, clicking on the Visit Topic link takes me to this thread.

Is there something else which might be affecting this which I haven’t considered. I’m new with using Postbox. This is only my second day.

OK. I just received an update to Postbox in the last couple of days. This has resolved this problem for me. The new release was after your testing. So we should have been using the same version. So I was perplexed why it worked for you but not for me. But anyway, the new release fixed it for me. Clicking on the link in the message now takes me to the page on the website. So this problem is now solved. Thank you.


1 Like