Cant enable reading mode?

I’ve set this, but cant see reading mode icon on search bar?

It appears to be a known issue, unfortunately.

Brave developers are actively working on SpeedReader though, you could give it a try to check whether it works all right for you.

You can enable it via brave://flags/#brave-speedreader.