Reader Mode not working

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting


Description of the issue:
Reader Mode not working

How can this issue be reproduced?

  1. No icon for reader mode

Expected result:
Icon to toggle Reader Mode

Brave Version:
Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (64-bit)

Additional Information:
Both Enable Reader Mode and Enable SpeedReader flags are enabled.
Cookies and cache cleared
Tried in Private Window (No extensions)

brave-reader-mode

Not every page will trigger speedreader or reader mode. I actually installed the Reader View extension on the Google Chrome store.

Thanks for the reply.

I don’t believe I’ve seen that icon in any page, and I was specifically trying to enable for a Wikipedia page. If Wikipedia will not activate Reader Mode, then it must certainly be broken.

I ended up just writing a userstyle for Stylus to get what I needed, but will look into the extension if I need it in other sites.

I’d be curious if others are able to get it working on wiki, or if there is something about my config that is breaking it.

Cheers

I don’t see it on Wikipedia either. I see Speed Reader activate more on pages like the Washington Post, AP News, or other news sites. It’s pretty sporadic. That’s why I added the extension. Reader mode on Vivaldi and Firefox work much better than Brave’s right now.

I don’t see it on either of those sites, so I guess it’s just broken on mine.

Cheers

To enable Brave Speedreader, you’ll have to set a flag for now (should be implemented in Release build very soon).

  1. Go to brave://flags
  2. Search for a flag titled Enable Speedreader
  3. Set value to Enabled
  4. Relaunch browser

You should then see the option to enable Speedreader in Settings --> Appearance:

I’m also seeing that you (@cynical13) or on an outdated version of the browser — please make sure to update to the latest build.

Flags were enabled as stated in my original post:

Additional Information:
Both Enable Reader Mode and Enable SpeedReader flags are enabled.
Cookies and cache cleared
Tried in Private Window (No extensions)

Updated Browser:
Version 1.36.116 Chromium: 99.0.4844.74 (Official Build) (64-bit)

I didn’t have either Reader Mode switch enabled under Settings -> Appearance

Didn’t seem to help though. (at least for AP News and Washington Post) I did restart and tried again in new private window.

Thanks for the tips though. Reading pages on an Ultrawide can be challenging and was just looking for a quick way to shrink it to the middle more than anything. I can just continue to use dev tools for a quick fix, or write a rule for pages I visit frequently.

Cheers

Sorry — you’re saying Speedreader does not work for AP news/Washington Post (and Wikipedia)? On my end, AP News and Washington Post offer me the option to turn on Speedreader for the site (and it does work). Wikipedia does not however — which is strange. I’ve asked the team about the Wikipedia case but they should be working on those other sites for you.

If I wrote that at home, it’s because I use Manjaro Linux and that was the most up to date version in the repo.

Yeah, I was saying that neither of those work and I can’t find a single site that works.

I really thought when I saw the switches were off under Settings -> Appearance that it would start working, but it just doesn’t.

I just not that worried about it that much, but I’m happy to check anything else if it will help determine the issue.

Thanks

Last question (for now) — when the switches are toggled “on”, you don’t even see the prompt in the address bar to enable Reader mode?

Exactly. Looks the same as my first screenshot of my address bar. Just the Brave Shield, and the Create QR Code icon. The Install Brave Community icon shows on this site too, but not elsewhere.

Here are all relevant areas in a single screenshot that I can think of. One oddity is that the QR code icon doesn’t appear until I click on the address bar. Not sure if this is normal or not, but clicking anywhere alse doesn’t raise the reader icon. I’ve clicked all around in case it was a styling issue and I just couldn’t see it.

@akovia,
To be clear, you are clicking on articles on AP News (or any of these sites) correct? The option will not appear on the main page.

In addition, can you also try visiting this exact URL [https://www.nytimes.com/2022/03/11/dining/induction-cooking.html] and tell me if it appears in reader mode (or if the option appears at least)?

1 Like

Now we are getting somewhere.

I certainly didn’t know it only worked on articles. That should help things for sure.
That said, it still didn’t work on this AP link.[https://apnews.com/article/russia-ukraine-kyiv-united-nations-europe-antony-blinken-c3310a12490a0cf2e06f5f389e22e3a6]

…but did work on the link you posted. So it’s nice to see it does actually work.
Here’s both.

I appreciate your help sorting this out. I had a misunderstanding of how it worked, so it may end up being mostly user error. It all started with Wikipedia which seemed like a perfect candidate, and after that I just wanted to see it work at all. Now that I know what to look for, I can enable it when it appears.

Many Thanks!

You’re very welcome. You may try clearing cache/data for the site and checking to see if this helps shake something loose. On my end, the link you shared works just fine with Speedreader:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.