Can't Download, SD Card not Found

Download Problem on Brave (Android)

When I download a file, I expect it to be on my Downloads folder on Gallery and File Manager.
Every other browser does that with no problem at all.

On Brave everytime I download something, It never appeared anywhere on my phone. All the downloaded files were not saved in /storage/emulated/0/download but instead it goes to a download folder inside the Brave app directory under /storage/Android.

App directories is not scanned by Android. So, I cannot find my downloaded file anywhere on the File Manager and Gallery.

Trying to re-download the file will shows dialog that SD Card not Found

Both happens on Brave and Brave Beta (1.5.100)
I’m using Xiaomi Mix 3 in Android 10.

Here is attached the location of downloaded file.

8 Likes

Same here, sometimes happen, mainly after re-install OS.
not known cause but related to the ¨order of installation ¨ of apps.
simply unintall-reinstall procedure works, at least for my circumstance.

1 Like

Re-Installing it did not fix the problem. I’ve been using both Brave and Brave Beta. Both are not working.

1 Like

this same problem also applies to oneplus 6 with android 10 os.

1 Like

it’s also still the case for me. it happened again and again.
temporarily, re-installation and grant the permission for the first download which doesn’t ask the directory to store, where the file will appear at /sdcard/Android/data/com.brave.browser… but once touch the menu Download, the symptom arises again, until reinstallation.
that’s all so far. the other same phone, same AndroidQ, has no problem at least until yesterday, which means some harsh update is the readon for this?

I have the same problem.
Impossible to download anything. I don’t even have an SD card and it’s not possible to change location. I’ve tried reinstalling twice.
Can mods comment on this please?

2 Likes

In the same boat. T-Mobile OnePlus 6t recently updated to Android 10. Unable to save files and see them on my phone. This app is completely useless to me now.

5 Likes

I have 2 PH-1s on the same android Q and One set up a few days ago has the problem, while the other set up a few weeks ago doesn’t. Both have same OS same version of Brave Browser, which confuses me what is the difgetence?

Same here.
Xiaomi mi 6 with custom ROM lineage 17 Android 10. Can download first file after installation, after accessing settings throws this error.

I have the same problem as Spexor.

I just upgraded my T-Mobile Samsung Galaxy Note 9 to Android 10, One UI Version 2.0.

1 Like

Hello,

Same here, just upgraded to Android 10 on my Galaxy S9.

1 Like

Yea, except my phone does not even have any Micro SD Card slot.

So this problem isn’t about the hardware. Looking by the trend of last comments, this problem is occurring on Android 10.

It cannot find the internal storage yet able to save the download within the application folder that falls under “Android” folder. But re-downloading attempt will results “SD Card not found”

1 Like

I can provide this information:
Bromite has the same issue.

Chrome however does not

Edit: Android 10 here as well. I didn’t have this issue before resetting my phone to factory defaults. No software updates were done before or after.

1 Like

I am also facing similar issue from past two days & going by the comments it seems like some silent updates were pushed into Android 10 devices. I also noticed that few inbuilt apps on my phone are not functioning & are now listed as not compatible on playstore. Even basic apps like Samsung Tutor is no longer compatible with my device. I spoke to Samsung and they said that they have indeed revoked support for few apps.

This obviously means they pushed some updates into android 10 device which rendered those apps useless & incompatible. These apps were functioning absolutely fine just two day prior to this sd card issue.
So, I can assume that this whole sd card issue is the result of some buggy updates. I request everyone to please check if there inbuilt apps are still showing up on playstore or not. Thanks

1 Like

I am having the same problem.
I rebooted my OnePlus 7pro (running Android 10) then, it wouldn’t work after that! “SD Card not found”

My device doesn’t event support an SD card.

1 Like

This just happened to me too. It OnePlus 6T upgraded Android, now I can’t download anything. Same error message. I can, however, download on Chrome. Is anyone working on this?

Same goddamn problem! Brave do something please.

1 Like

Can we get a comment on this already?

1 Like

Same here, after updating to Android 10

1 Like

The team is aware of this issue and we are digging into it presently.

2 Likes