Can't download dictionary spell check

I tried this and it did not work, same as before error.

Can you try going to Settings > Update & Security > Windows Security > Firewall & network . Select Allow an app through firewall. Select Brave and then ok. And then try the download again.

In that windows, brave has access to both private and public options, should I disable them as they are enabled?

1 Like

You can leave it as is, looks like Brave already has access.
I’ll make a note of the issues and speak to the team to see if we can further diagnose or solve the issue.

Thanks for your help so far. A quick question, is there a way to back up all my data and then do a clean install of Brave Browser?

We got a thread here talking about that.

The path is: C:\Users\[Your User Name]\AppData\Local\BraveSoftware\Brave-Browser\User Data
In the user data folder, there is another folder called Default. That Default folder contains all your important info. You can make a copy of it and paste it into a new installation of Brave. Please see the thread for more details. Please keep in mind this method is not perfect, and may not work for everyone.

Thanks @Aa-ron , will give this a go and report back if it helps.

1 Like

I’ve got the same issue. I’ll be following your discussion guys.

Can you tell me what your location/region is in your systems settings? And the default language?

Everything is set to english and my location that is set in system settings is United States but take not I am not from US. I set the US as I want my pc to be on english and not on my native language.

I am encountering the same problem on a fresh install. Trying to download either English (Canada) or English (US) dictionaries from settings produces the error:

Spell check dictionary download failed.
Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave Software servers.

Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

Hosts file is clear, have tried disabling firewall. System language is English (Canada) on Windows 10.


Hey @orreryo,

By the looks of it, there is nothing on our side to fix this issue. Let’s hope Aa-ron will speak with the team about this problem so they can fix it. Cheers man.


Same problem here, on a fresh install of the OS and the browser

Trying to download the Brazilian Portuguese and English (United States) dictionaries.

Brave info

Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) unknown (64-bit)

Package info

brave-bin 1:1.10.97-1
AUR Link

Error Message

Spell check dictionary download failed.
Please check with your network administrator to make sure that the firewall is not blocking downloads from Brave Software servers.

hosts file localhost
::1 localhost arch.localdomain arch

System information

Linux arch 5.7.5-arch1-1 #1 SMP PREEMPT Mon, 22 Jun 2020 08:10:02 +0000 x86_64 GNU/Linux

1 Like

Hello. I’m having the same issue here on a fresh install of win 10 pro and latest version of the browser.

I’ve just installed Brave…and there is not an operational spell checker…I’ve been following along, clean hosts file…same error as everyone…so this issue has not been resolved? I don’t want to delete the Brave install, but if it cannot use a spell checker, what the heck else is there to do?

Just noticed I’ve got this issue also

Same problem here.



same issue, hope they can solve it, we can arrange a remote session if it helps

Yep, same issue here :frowning:

I tried all the steps above and nothing resolves the issue.
I guess we’ll see how quick Brave Support are at addressing community issues.

I can hear a Brave Tech now… “why don’t hey just bloody learn to spell!” …lol :slight_smile:

Anyway, hope the fix comes soon. Have to use Firefox ATM for website Posts as it’s spell check actually works.

I’m not sure if this helps or not as to why it’s not working.

I noticed that if I type into the Google Search Field the Spell Check works even though it tells me the D Spell Check download failed.

I use Microsoft Word and Outlook on Brave and the spell check works there as well.

If however i type a post on FB, or search in Youtube or Tweet on Twitter then the spell check doesn’t work. I’m guessing that Word and Outlook might have their own spell check working even though I’m on the Brave browser, but not sure why Google search field is working with the spell checker?

Anyway, thought i’d add this info just in case it helps to figure out what the problem is.

Cheers :slight_smile: