Can't download any files. Coming out as .com.brave.Browser.JXcGpG files

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete the any text above the line separator below before posting

Description of the issue:
How can this issue be reproduced?

  1. Went to
  2. Scrolled down and clicked on “free download”

Expected result:

All I get is a hidden .com.brave.Browser.* file. No matter how many times I click download. That’s all I get.

Brave Version( check About Brave):

Version 1.17.75 Chromium: 87.0.4280.88 (Official Build) (x86_64)

Additional Information:

Went to another font site and still the same issue.

Greetings, try another Source Finder since many of the Source addresses may not be suitable depending on the program in which you use them, try to copy the URL / Link of the download with a second click and open it in Anonymous Mode or directly from the Browser By pasting it, the direct result may work for you, if not, copy the Name and in your Search Engine look for another Download place, it may be a download Server problem with your location.

Interesting – on my end I’m getting the appropriate file using the same link. Can you run a quick test and try creating a new browser profile (Menu --> Create profile) and see if you get the same results when you try to download the font?


Interestingly enough that worked. Any reason why the my first profile would be giving me the download error?

Also, the .zip download seems to be greyed out. After I unzip it, the folder is greyed out as well. But the contents in it seems to be fine. Not sure if it’s an issue or not. But it will leave me being unsure if a download is complete or not.


1 Like

It’s either an extension you have that’s conflicting with the DL process (which seems unlikely, as it seems you only have Pintrest extension installed) or some bad cache data causing the conflict. To test, return to your default profile and clear your browsing cache/data and you should see the issue resolve.

Hey Mattches,

Appreciate all the help. I just ended up deleting the old profile. If this happens again, I’ll try and keep note if I make any changes or visit some particular site that might be giving me the issue.

Thanks again!


Thanks to you for sharing your question, thanks to this type of doubt users who follow your publications can learn and solve future doubts, I invite you as a Brave Browser user, if you have any questions about this reference or another, publish it in the Community so you complicate, or be it very simple, we will gladly help you and learn from you so that you or more users can resolve their concerns in the future, Thank you.