Can't connect to site with self signed certificate

Hi,

I can’t connect to any site with a self signed SSL certificate.

I understand the warning, and every other browser also presents the warning, however they include a “proceed anyway” link so that I can still go and configure my router, IPFire firewall, whatever it is I’m accessing that has a self signed certificate.

It is becomming a pain to have to switch from using Brave every time I need to access my router settings. Is it possible to fix this? Or is the fix to switch to Firefox?

Thanks

Hi @JustAnotherLapras

This comes from Chrome, We haven’t changed anything here. I have the same error message when connecting to Unifi Udm. Both Firefox, Brave and Chrome will show these messages

Brave:


Firefox:

Yes however quite clearly in your demonstrated example you have a “proceed anyway” link… my “proceed anyway” link is missing SO I CANNOT PROCEED!!!

The difference is that with Firefox I can proceed, with Brave it is totally hopeless I cannot proceed I have no choice but to use another browser. @fanboynz

Just click on "Advanced" button, then click " Proceed to ...". The next question, what happens when you click on Proceed?

@fanboynz it’s not there, there is no “proceed” it’s totally missing

I’ve seen others say the same problem and you literally give them the same nonsense response and they don’t bother to re-explain it to you.

Reminds me of https://github.com/brave/brave-browser/issues/14216

Can you try in private window mode, or if Brave Beta resolved it

Exact same problem exists in private window.

Problem also remains with beta. It looks like the wrong exception is being thrown for self signed certificates.

Screenshot of the wrong exception?

You can see above, ERR_CERT_INVALID maybe it should be a self signed exception or something not invalid? invalid suggests the cert cannot be used, but that’s not the case as any other browser can use it just fine.

Interesting, a difference between mine and yours, “NET::ERR_CERT_INVALID” vs “NET::ERR_CERT_AUTHORITY_INVALID”. What does Chrome show?

Couldn’t tell ya, it’s not going anywhere near my machine.

Try enabling brave://flags/#allow-insecure-localhost, other than include https everywhere, cert restrictions shouldn’t differ from Chrome.

I tried that flag, it doesn’t work because I’m not hitting localhost (127.0.0.1) so the flag is not relevant, but I did give it a go just incase it was scoped to private IPs as well, sadly not the case.

Firefox & Safari opening it fine, they show the warning of course, because it is serlf signed, however both allow me to proceed.