Thisisunsafe no longer working

I work with a LOT of devices with embedded webservers with TLS/SSL turned on and self-signed certificates. A few weeks back, the Google-born fix of typing “thisisunsafe” to bypass security errors such as “NET::ERR_CERT_DATE_INVALID” stopped working. This forces me to use Firefox or Safari to get any work done.

How can this issue be reproduced?

  1. Point Brave to any site with an invalid TLS/SSL certificate, either self-signed or out of sync (more than 5-minutes off on its clock) or expired.
  2. Click somewhere in the browser not on a link. Type “thisisunsafe”
  3. Be sorely disappointed.

Expected result:
Should have opened the site and just left an unsafe/broken lock icon in the location bar while functioning normally.

Brave Version( check About Brave):

Version 1.56.20 Chromium: 115.0.5790.171 (Official Build) (x86_64)
and have tried after several updates.

Additional Information:

In my case I also noticed in the security settings that I’m unable to switch from No Protection (Safe Browsing) to Standard protection; no idea why unless CorpIT has been messing with my settings through ManageEngine or JamF again. I’m on MacOS 13.5.

what about starting Brave with --ignore-certificate-errors

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.