Cannot Send eth from Brave Wallet (internal) to MM

So it sounds like this is a well-known issue/bug and that it has existed for at least a month with no apparent resolution from @Support ?

I have ETH sitting in Brave’s internal wallet, that I was able to successfully transfer in from Coinbase. I was unable to use the Brave wallet to mint an NFT. Each time that I have tried transferring money out to my MM wallet, it will appear in the transaction log as “Submitted”.

Never shows up in Etherscan, never arrives in my MM wallet. But gas trying to do so definitely gets charged.

Please provide steps on HOW I can get this money out of the Brave Wallet. Or Brave’s mailing address for legal correspondence.

Please and thank you.

Are there transaction hashes for the submitted transactions?
Gas would only be used if the transaction was accepted.

Apologies for delay, thank you for replying @brian . When trying to transfer from Brave Wallet → Metamask, the account log shows “Submitted” but doesn’t show up in Etherscan (“Unable to locate TxnHash” . So I guess it’s not charging gas on those?

If I try to transfer from Brave internal Wallet to a Trezor that’s connected (and shows up within Brave’s UI), the log just says “Error” as the image shows, with Block Explorer URL unavailable.

I am not manually changing the gas setting either way, and I’ve also tried only transferring 75% of the balance (with that 25% more than enough for gas).

So I’m at a loss and worry the money will be entirely lost if the HDD goes for whatever reason soon. I’m using a pop_OS (Linux) and version 1.33.106 Chromium 96.0.4664 … if that makes a difference.

Is it possible to import the Wallet into the Brave installation on a Windows machine? Would that make any difference?

Please help soon, thank you.

But if I hover over the little “chips” icon next to the transaction amount, all of the error transactions DO say “Transaction Free: 0.002 ETH” (amounts vary for each one).

I wonder if there’s a transaction nonce problem.
We have the ability to reset that in the next version of Brave which is set to release around ~March 1.

I wonder for now though if you could try creating a new profile and then restoring it there, that would effectively reset the nonce information. Then see if the problem reproduces there?

I don’t even know what nonce means so I probably just should wait until new release…?

In the meantime, is there anything else I can do as “backup” to help protect the funds in case my HDD goes bust? Got the recovery phrase obviously, do I need to save the wallet address as well? Never had to restore a wallet before so don’t know if I can even just add it to a different machine and try to transfer out from that one.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

FYI this was released in 1.36.x. You can clear local transactions if you’re stuck in brave://settings/wallet and you can also set the nonce at a transaction level now too.