Cannot open browser on Mac (M1) BigSur 11.6

Description of the issue:
I am a first time user on a Mac (M1). I went to the website and downloaded the browser (I tried both ways - using .pkg and also .dmg).

When I click to open it I see a dialog box saying “Brave Browser quit unexpectedly.” When I click the “Reopen” button, I see the same dialog. I have never been able to open it.

How can this issue be reproduced?

  1. On an Apple Mac (M1), running BigSur 11.6, download the ARM-64 version of the browser
  2. Click to open the browser

Expected result:
The browser should open

Brave Version( check About Brave):
95.1.31.87 (131.87)

Additional Information:
I have seen some help articles say that users should try to open with the “–disable-gpu” argument - I have tried this and it doesn’t work.

I have also seen suggestions to check that any previous browser data is deleted from files stored in Library/Application Support/… but I have no such data on my computer as this is the first time I’ve tried to launch it.

1 Like

Thanks @lachre for reaching out, welcome to Community :smiley:

Did you download Brave from the official Brave website? https://brave.com/

To see hidden files on MacOS, you can press these hotkey Command + Shift + . (full stop/period)

Hi @SaltyBanana Yes, I downloaded it from the official website, and below is what is in the BraveSoftware folder:
image

I have the same problem. I’ve downloaded the BRave browser from the official website. I also tried uninstalling (properly with all files) and installing the intel version of Brave, but I’m running into the same problem. Please help :slight_smile:

1 Like

I’m having the same issue, were you able to resolve it?

Hi, I have the same issue :frowning:

Thanks

Nope, I have not been able to resolve it. Still waiting patiently for some guidance…

Hi all, for those who are downloading Brave from the official site. If you have M1 Macs, select the M1 download.
Let me know if this issue still persists.

@SaltyBanana I did select the M1 download - I posted that fact in my first message. The problem persists.

The problem persists.

I am having the same issue. M1 Pro Macbook Pro, MacOS Monterey 12.0.1.

Are you folks using any 3rd party security (antivirus/antimalware) software on your macs by any chance?

I am not using any 3rd party security software - no.

No 3rd party security software on my end.

Same problem, I see it is a BIG problem…

1 Like

Hey, any news on this? I have the same problem with Brave on macOS Monterey v12.0.1 chip Apple M1, downloaded from official pages.

1 Like

Still waiting for an answer …

Huge fan of the BAT and Brave browser, conceptually. Also an owner of BAT crypto.
I like what you guys are doing.

BUT… Not having any success at all using Brave browser on my MacBook Pro, macOS Big Sur 11.6. I understand growing pains, but this is basic. Hope you can get back to people on your customer support.

Your core supporters will be on Mac products.
How can this problem be solved???

Thx

I’ve got the same problem, Brave won’t open on iMac 2021 with M1 processor.

Hi admin,

Is there any feedback on this error? I am also experiencing this error when i download the brave browser from the main webpage under the M1 chip.