Bugged: Setting Brave as default browser in iOS


Brave 1.20 can now be set as default browser for iOS 14.

However, it doesn’t seem to be working correctly.

How can this issue be reproduced?

  1. Swipe down from the home screen to search.
  2. Enter some search terms.
  3. One of the results in the list will be a Brave browser icon with the search terms next to it. Tap it.
  4. Brave browser opens but does not navigate to any search page for the terms.

Expected result:

  1. Brave should open a new tab and navigate to search results for the specified terms.

Brave Version( check About Brave):
iOS 1.20 (20.09.11.20)

Mobile Device details
Apple iPhone 11 Pro

Additional Information:
Tested this scenario with Chrome and it worked as expected.

1 Like

works for me, opens a new tab and search results are shown

what search engine you have set as a default? I tested google and all looks good to me

works for me, iPhone 7 IOS 14.0.1

I don’t have any issues. So you should try these troubleshooting steps.

First, I would try setting your default browser to Safari and then set it back to Brave. If that doesn’t work, try doing the same above and then hard restart your phone by tapping the volume up, tapping the volume down, and then hold the side button until you see the Apple logo.

Thanks— turns out just doing a swipe up in Brave did the trick, and all works as intended!

Just for my future info, what do you mean by a swipe up in Brave?

Sorry, a swipe up on Brave in the iOS task manager. Basically a soft kill.