Bug and Potential Solution: Missing Windows Taskbar Jump Options (New private window...etc)

Issue:
There are currently only 3 selections available on the Brave taskbar jump options (see supporting screenshots) and these are the Windows default jump options. The jump options that were previously available (e.g. New private window) are no longer available.

Potential Solution:
I did some digging and found this has happened on Google Chrome in the past and somebody found a solution (https://support.google.com/chrome/thread/12246911?hl=en&msgid=15133149). This solution will not work for Brave.

The reason this solution will not work for Brave (based on my further investigation) is because the Custom Destinations file (.customDestinations-ms) for Brave is missing (C:\Users%USERNAME%\AppData\Roaming\Microsoft\Windows\Recent\CustomDestinations).

There should be a Custom Destinations file in the above directory that matches the name of the directory for Brave found in the Implicit App Shortcuts folder (C:\Users%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts).

My Brave Version:
Version 1.4.95 Chromium: 80.0.3987.122 (Official Build) (64-bit)

Supporting Screenshots:
BraveJumpMenu

Final Notes:
If you have any further questions in regards to this issue, please don’t hesitate to ask and I’ll do my best to find the answers.

1 Like

FWIW, I have a number of browsers installed …
Oh, and BTW, they’re technically called “Tasks” on Win “OS”
a) Chrome Canary - Tasks are missing
b) Chrome Dev - Tasks are there
c) Chrome release - Tasks are there
d) Opera - Tasks are there
e) Brave release - Tasks are missing
f) Brave Dev on Linux - (“Actions” on Linux) those options are there [1]
g) Brave on Android - Actions are there

So yea, even on the Canary channel, it’s missing.

[1] Obviously you’re only concerned about Windows. For me, that’s only a test laptop … all my daily workhorse machines are running a Linux distro.

Might try Brave Dev on Win to see if it works.

1 Like

Thanks for the contribution @caldercay !

I can confirm that this issue is written in regards to the Windows 10 application.

To be clear, (a) - (e) are on windows

I’ve finally managed to fix it. Here are the files: mega.nz (VirusTotal).

Download and extract zip. Press Win + R and paste these paths one by one and press enter:

C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Windows\Recent\CustomDestinations or %AppData%\Microsoft\Windows\Recent\CustomDestinations

and

C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Windows\Recent\AutomaticDestinations or %AppData%\Microsoft\Windows\Recent\AutomaticDestinations

and

C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts or %AppData%\Microsoft\Internet Explorer\Quick Launch\User Pinned\ImplicitAppShortcuts

Now go to the extracted zip, open folder (for example AutomaticDestinations) and copy the files to the folder with the same name (AutomaticDestinations). Make sure you do this will all three folders. This worked for me in VM and on my PC.

1 Like

That works perfectly, except that the text is in Czech. I don’t think it’s possible to edit those files either (I’ve tried Notepad, Visual Studio, and another specific tool).

Would you happen to have an English version of those files or where to get those? I tried installing an older version of Brave to get them myself, but that doesn’t work because it always installs the latest version of Brave. I can’t find those files anywhere else either.

1 Like

Here’s the english version:
https://files.catbox.moe/vw0xqk.zip

For me the only file that needed to be added was
407962ce3d4220f.customDestinations-ms
inside
C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Windows\Recent\AutomaticDestinations

1 Like

Hi. Apologies but I don’t really understand this well enough. i must’ve did something wrong and nothing is happening. would you mind going into more details? or a video would be helpful. Thanks a lot

That worked for me too, but the path for 407962ce3d4220f.customDestinations-ms is unfortunately wrong given.

Here’s the correct path: C:\Users\%USERNAME%\AppData\Roaming\Microsoft\Windows\Recent\CustomDestinations