Browser window get bigger on linux

suddenly I notice this issue on linux.
I’ve tried linux mint, lite & manjaro… all have same problem but windows 10 was fine!
when I open my brave browser… its normal
image
but if I minimize & open again from taskbar… the browser window get bigger
image
how can I fix this?

1 Like

What version of Brave?

If it’s not 1.31.87, please update and try again, there were some other weird display issues on Linux reported here recently that I think went away with the latest version.

Otherwise – what version of Mint? What installation instructions/process did you use for the install?

If you’re already on 1.31.87 I can try later on my Mint VM and see if I can reproduce it.

I followed brave official download method

sudo apt install apt-transport-https curl
sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg https://brave-browser-apt-release.s3.brave.com/brave-browser-archive-keyring.gpg
echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list
sudo apt update
sudo apt install brave-browser

I’ve tried mint 20, lite 5.4 & manjaro 21
all have same issue!

not happening in ubuntu 20.04

my problem has solved but not fully…
the problem was chromium version 95!
I installed an old release of brave.deb from github… now my problem fixed :blush:

1 Like

Glad you got it resolved!

You might want to try Brave again at 1.32.x, which will be on top of Chromium 96, due around mid-November. Then hopefully you can move on!

I can confirm that for V1.31.87 (Oct 19, 2021) on xubuntu 20.04.3 this is happening.

When I have Use system title and borders set to off the window borders show and maximize - by double clicking the title bar - no longer over extend the top.
If I toggle it fixes it however as soon as I maximize the but occurs again.

  • I have multiple monitors in this configuration set up via display and arandr - tried them both.
[ ][ ]
  [ ]
  • The bottom middle monitor is my primary and it has a toolbar at the top.
  • Changing the displays so they’re [ ][ ][ ] with the primary monitor in the middle produces the same result.
$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.3 LTS"
  • In Window Manager I’m using the Default-xhdpi - changed that to another - issue still occurs…
  • In AppearanceFonts I’m using the custom dpi of 100 with it enabled/disabled - issue still occurs.

I also followed the official download method.

Same here.
Brave version - 1.31.87
Debian 11
Xfce 4.16

I can confirm here as well on:

Brave Beta: 1.32.81
OS: Xubuntu 21.19

Same here. Xubuntu 21.10 on both Brave Stable (1.31.88) and Beta (1.32.86).

Is it fair to say that everyone with this issue is using Xfce?

I wonder if it’s the same issue as this: https://community.brave.com/t/brave-opening-with-invisible-borders-that-break-the-previous-size-updated-v1-30-86-v1-31-87

Another user has posted a workaround for affected Xfce users: When maximized, brave does not respect screen bounds - #21 by Karl.Redman

2 Likes

Nope, did not work for me.

Xubuntu - Version 21.10.
XFCE - Version 4.16
Brave - Version 1.31.91

I created an Account explicitly to make sure this thread remains open.

The Solution Posted by [JimB1] asking to change the Theme from Classic to GTK+ is a little better than before. But it can’t possibly be called as a solution to this issue. Please keep the thread open.

Agreed that’s not a ‘fix.’ However I think it’s likely this issue will magically go away when Brave 1.32.x lands, which is scheduled to happen in a few days and appears to be on track.

The issue appears to originate with Chromium 95, and the Chromium team believe it’s fixed in 96. And 96 will be the Chromium base for Brave 1.32.x.

It’s possible that that specific bug isn’t the actual issue here, I saw another Chromium 95 bug that might also be causing it; but there’s a good chance that will be fixed in 96 as well.