Brave UI is very disturbing and bad

i’ve been using brave browser for a while, i’m using it in Windows, Linux and Android device.
UI was so good and as usual, i reinstalled Linux OS and Windows OS, installed after that brave browser on both of them, Windows got normal UI , but in Linux got very bad (see screenshot below)
i reinstalled brave, deleted all configuration files, restored default themes, default parameters, but nothing worked, is there any solution to fix the UI?


1 Like

Hello @DevProd

could you explain which part of UI that you do not like or maybe a screen short to the target UI you want
also what is your desktop environment you use?

and have a nice day :slight_smile:


Hi, I’m using Gnome, Brave-bin
To understand what I’m trying to say, try to compare attached screenshot of my brave window with yours (or brave window on someone’s Linux OS)
I’ve used brave on gnome before and UI was good without any problems.
In the attached screenshot there are to major problems:

  • URL/Search bar : font size is too small and it’s content is hard to read.
  • UI elements as download pane (in the bottom of the screen) : is too large.

Hi @DevProd

thanks for the info

  1. go to setting in gnome then you have 2 way (those option affect the whole system):

    A) go to display and change the screen resolution
    B) go to accessibility and check the large text option

  2. for the download bar area i know it large but that for all of us and there no resize option for that but there are work around for that one if you interested go to brave://flags/#download-bubble and enable the download-bubble and notice if the new ui for the download is good for you or not also you can enable the download bubble v2 (this require to enable the first one also) and see which one you like more

hope that help and have a nice day :slight_smile:

1 Like

thank you sir for your time, but these instructions didn’t help, i saw the changes happen to other UI windows, but nothing happened to brave window and kept as it is
thank you in advance

you welcome but sorry i have no other idea so wait till one of the team help you about that and have a nice day :slight_smile:


thank you sir for your time :upside_down_face:

1 Like

@DevProd you welcome :slight_smile:

Under the Settings → Appearance menu, have you tried changing between the themes? If you’ve got classic, try GTK or vise versa?


i fixed it by removing brave-bin and installing brave, then reinstalling brave-bin.
i don’t know how this worked but it worked and now text is readable and UI got restored as used to be.
thanks everyone for your time , i appreciate it :heart:


you welcome and congratulations :partying_face:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.