Browser is having issues with wss (websocket secure)?

Description of the issue:
I noticed that logging into https://video.ui.com doesn’t work in the browser even with shields turned off. Below is the request within the dev tools that is failing

REQUEST HEADERS
GET wss://device-airos.svc.ubnt.com:8848/api/airos/v1/ufv/events HTTP/1.1
Host: device-airos.svc.ubnt.com:8848
Connection: Upgrade
Pragma: no-cache
Cache-Control: no-cache
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
Upgrade: websocket
Origin: https://video.ui.com
Sec-WebSocket-Version: 13
Accept-Encoding: gzip, deflate, br
Accept-Language: en-US,en;q=0.9
Sec-WebSocket-Key: xxxxxxxxxxxxxxxxxxxxxxxx
Sec-WebSocket-Extensions: permessage-deflate; client_max_window_bits

RESPONSE HEADERS
HTTP/1.1 401 Unauthorized
Date: Fri, 12 Jul 2019 22:51:43 GMT
Content-Type: text/html
Content-Length: 12
Connection: keep-alive

I can use chrome with no issues. Are there any workaround to this problem?

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Not sure you can repo the problem directly unless you have an account with this service.

Actual Result (gifs and screenshots are welcome!):

Expected result:
It doesn’t error and prevent it from loading

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10, 1809, 17763.593
Version 0.66.99 Chromium: 75.0.3770.100 (Official Build) (64-bit)

Additional Information:

cc @Mattches @gsarvadnya @sriram on this

@sflanders,
Can you try disabling HTTPSE upgrades in Default Shields settings? This wouldn’t be a real solution but I am curious if that what may be causing the issue.

Same issue occurs with those turned off. I actually tried that originally to see if it got past the problem

@sflanders,
Do you have any additional extensions installed in Brave?

just lastpass and session buddy