Browser crashes when opening Autoplay setting

Description of the issue:
The entire browser immediately closes when I open the Autoplay setting under Site and Shields settings permissions

Steps to reproduce:

  1. Launch Brave
  2. Open Settings menu
  3. Navigate to Privacy and Security section
  4. Click Site and Shields Settings
  5. Under “Permissions” click "Additional permissions
  6. Click Autoplay

Actual result:
Browser crashes.

Expected result:
Change Autoplay setting.

Reproduces always.

Brave Version: 1.29.77

Additional Information:
I’m using Windows 10 version 20H2

@UziasMaki

Developers are aware of the issue, hopefully they’ll commit a fix soon.

The issue has been resolved in Brave Version 1.29.80, released a few hours ago.

The issue is also present in Mac OS Big Sur 11.6. Brave is up to date as of Sep 15,
Version 1.29.81 Chromium: 93.0.4577.82 (Official Build) (x86_64)

@gibson

I let a QA team member know about your issue.

https://github.com/brave/brave-browser/issues/17808#issuecomment-920058787

@gibson do you have any STR? I basically just tried the following and couldn’t reproduce the original crash that we fixed via https://github.com/brave/brave-browser/issues/17808.

STR/Cases used:

  • launch 1.29.81 Chromium: 93.0.4577.82 which is the latest release
  • visit brave://settings/content/autoplay via the URL
  • visit brave://settings/content/siteDetails?site=https%3A%2F%2Fbrave.com via the URL

Used the following MBP:

OS: macOS Version 11.5.2 (Build 20G95)

I tried it on Win 10 x64 as well just in case and couldn’t reproduce. If you can provide us with some STR/Cases, we’ll try reproducing/fixing. Could you go into brave://crashes and see if there’s any recent entries in there? If there’s crash reports, mind sending them and sharing the Uploaded crash report ID?

1 Like