Browser clock is set to system clock and not local time

I have the system clock (BIOS) set at UTC time, and have the OS (Fedora Linux with Gnome desktop) set to my local timezone (-4 UTC). Brave shows UTC time on its clock and any website I visit. How may I configure it to the local time set by the OS?

Brave Version:
Version 1.41.96 Chromium: 103.0.5060.114 (Official Build) (64-bit)

If you open a terminal and run date from the shell, what do you get?

I get my local time (11:00 am, -4 UTC) as expected. The browser, though, registers my BIOS time which is UTC (currently 3:00 am).

By ‘its clock’ do you mean the large one shown on the New Tab Page? And ‘any website I visit,’ so for example if you go to you see the BIOS clock value there as well?

Do you happen to have any other browser on there, such as Chrome, Chromium, or Firefox, and does the same thing occur with that?

Also did you install Brave using the instructions on the site (using the Brave upstream repo) or did you use some other method?

(post deleted by author)

I did follow the recommended procedure for installing Brave on Fedora. And shows the correct, local time.

But on the big clock at the New Tab page it shows the incorrect UTC time (BIOS time).

And also, see these screenshots from Reddit, the same post, and on the mouseover info from its posting time, each browser displays a different time.

Here Firefox shows the correct local time:

And here Brave displays the wrong time, from the BIOS:

This can also be observed on the times displayed in the chat applet of Reddit, as well.

And by the way, this bug also happened on Chromium, which I tested to the same results. So the issue might come from upstream.

(EDIT: sorry, the captions on the screenshots are messed up, the correct caption is right above the picture)

1 Like

OK. Yeah, this is a strange one. But I’m glad you pointed out that it affects Chromium as well.

I’m guessing if you open the browser Console (Ctrl+Shift+J) and enter the following, you’ll get the GMT/UTC (wrong) time back?
new Date()

I did find this older Chromium thread which looks very similar, but it seems Windows-specific:

Potential workaround by setting the TZ environment variable:

Also, definitely upgrade to 1.41.100 if you haven’t already.

It did, but then I adjusted the TZ environment variable, as suggested on the thread you linked, and it worked!

Thank you so much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.