Browser becomes unresponsive when opening new tab every time,

Description of the issue: The browser becomes unresponsive for about 5 seconds when a new tab is opened. My hardware is completely fine.

Steps to Reproduce (add as many as necessary) Open a new tab

Actual Result (gifs and screenshots are welcome!):

Expected result: That an internet browser doesn’t lag opening a new tab

Reproduces how often: Every time

Operating System and Brave Version(See the About Brave page in the main menu): Microsoft Windows 10 home

Additional Information: Hardware acceleration is disabled, I have disabled the background images, I have disabled the widgets.

9 Likes

I’m having the exact same problem. Every time I open a tab it takes about 5-10 secs for it to load. That’s ridiculous. I’ll switch back over to Firefox before I sit waiting for a tab to open. Just started today. This is with everything on the dashboard turned OFF. I just noticed this Binance. Is that the cause? And if so, why is it still lagging with it turned off? Is it still loading but just not showing it? This goes against everything I thought Brave was about.

5 Likes

Same exact problem, ever since that binance window showed up it’s been like this, takes a good 6 seconds for the browser to become responsive after opening a new blank tab. However when opening a new tab through a link no lag happens.

5 Likes

I have the same problem as described above when opening new tabs pressing Ctrl+T. Brave lingers for a few seconds and then shows the page.

3 Likes

Perhaps, it is the new update 1.8.86 that is the culprit of the clumsiness. Is it?

3 Likes

thought i was the only, this problem started a day ago for me, its annoying as f*ck, fix it please

4 Likes

I was surprised that I am not the only one expriencing the same issue…
Open a new tab and loose your control on the browser for at least 15 seconds and every and each time…
A very big disappoinment on me…
Is there any one for a solution on the Brave side.?

4 Likes

I found a solution to this issue.
Rather than a solution, it is turn around but does the job and opens a new tab without any wait situation.
SHIFT-CONTROL_T “reopens the closed tab” without any hesitation, as the same menu item on the left button of mouse. “new tab” and Ctrl_T is a problem maker. Don’t ever use it until BRAVER bodies resolve it.

4 Likes

Or if you don’t want to click 3 keys at once, right click the top area and click “reopen closed tab”

3 Likes

Having the same problem as well, and I agree it might be the new widget that they added that is the cause.

2 Likes

Which is weird because even if you turn off the widget, it still lags for 8 secs. It’s this kind of thing I came to Brave to get away from…

6 Likes

Having the same problem. Pretty sure it’s related to bookmarks. I’ve completely reset Brave and created two profiles, one with my bookmarks imported and one without. No extensions or other modifications.

The one with the bookmarks quickly started showing this problem again while the one without the bookmarks imported continued to function no problem, snappy and responsive no matter how many tabs I have open. And this is while having browser windows open for both profiles simultaneously even.

The browser window for the profile with the imported bookmarks locks up all of Brave when opening new tabs or windows. The profile without my bookmarks imported doesn’t.

Clearly this appears to be related to changes that went into the new build containing the new Bitcoin widget that everyone just got, but I suspect not it’s directly related to the widget itself.

4 Likes

Happening for me too - Version 1.8.86 Chromium: 81.0.4044.129 (Official Build) (64-bit) - macOS 10.15.4
Only happened after the last update. Hangs for 7-8 seconds every time I open a new tab. Made no changes to bookmarks or anything like that. Everything has been great up till now - have been using for a month or 2. If this carries on I will be going back to Firefox!

3 Likes

Same problem. Annoying as f_ck.

Adding the option to simply revert back to the previous update / version until the next update comes out would be a very welcome, and seemingly low effort fix for not only this, but similar problems in the future.

6 Likes

Try this:
Go to Settings > Additional Settings > Reset Settings > “Restore settings to their original defaults”

On previous 1.7.98, doing this solved the freezing issue that some users had back then.
Not sure if this will work, but it doesn’t hurt to try.

NOTE:
AFAIK “Reset Settings” is safe and will only clear your settings, cookies, & site data. Your bookmarks, history, and extension settings won’t be cleared or changed (not sure about saved password though). But make backup of your BAT just to be safe. Also backup your entire profile folder. On windows, it’s on %localappdata%\BraveSoftware\Brave-Browser\User Data

2 Likes

Tried it. Didn’t work.

Reset brave starts on new tab. Tab takes 8 secs to load. New tab, another 8 secs. Thanks for the try but it had no effect.

2 Likes

what widget ? …

1 Like

i can’t just reset brave, i have too much sh*t going on … bookmarks, addons,saved passwords, …

2 Likes

Their bitcoin widget. Binance

what they where using before was working fine and not causing any problems for me. The switch to this one and broke something causing the issue whenever you open a new tab.

1 Like