Broken Script on YouTube Comments

Description of the issue: The YouTube comment section is broken on Brave Browser using ios 15.5. The issues include:

  1. Clicking the “Comments” tab fails to open the comments section unless I refresh the page or double click the down carat to open and close the video description.
  2. More troubling, replies to comments now fail to load completely, we’re talking spinning wheel of death. This issue is refractory to clearing all browsing data, cookies, cache, you name it, the issue persists. I closed and reopened the browser and restarted my device with no change. (Also, I of course have “Blocks Scripts” DISABLED in the privacy settings. I have also tried disabling “block fingerprinting” and going fully shields down which have not solved the issue)

How can this issue be reproduced?

(1) occurs sporadically while using the site while (2) occurs persistently— can be reproduced by simply opening YouTube now. It may be worth noting that I first noticed (2) immediately after attempting to leave a reply to a comment.

Expected result:
Replies to comments fail to load.

Brave Version( check About Brave):

Version 1.38 (

Mobile Device details

I’m running iOS 15.5 on iPhone 7

Additional Information:
I’ve been switching to brave as my default browser purely for discrete and effective adblocking on YouTube. I hope that my concerns are taken into account for the benefit of users like me.

EDIT: Deleting and reinstalling brave straight from the App Store results in the same issue. The problem is clearly between Brave and iOS 15.5

EDIT#2: The problem (2) spontaneously resolved after several hours…regardless there’s something malfunctioning between Javascript on youtube and Brave. I feel like leaving another comment reply might reproduce the issue but I don’t want to risk breaking the site again

1 Like

Please let me know if the issue occurs again and we can take a closer look. On my end, I’m able to view and leave comments on YT videos without any issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.