Brave Youtube 1080P 60 FPS massive fps droppage

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Brave YouTube 1080P 60 FPS video massive fps droppage:

How can this issue be reproduced?

  1. Go to
  2. Search 1080P 60FPS Clip
  3. Playback will engage with the default playback setting 1080P (60 FPS)
  4. Stat for Nerds will show frame drops. The video will automatically reduce to 720P (60FPS) with no significant frame drops.

Expected result: Should handle 1080P 60 FPS with no Frame Drops resulting smooth playback.

Brave Version( check About Brave):
1.52.130, Chromium 114.0.5735.198

Mobile Device details
Motorola Moto G Stylus (2021)
Qualcomm SDM678 Snapdragon 678 (11 nm) & 1080P panel, Android 11.

Additional Information:

Firefox Android plays exactly the same video at 1080P 60 FPS with no frame drops.
Native Youtube app also plays 1080P 60FPs with no frame drops.

is latest chromium build artificially messing around with the codes for older hardware? I use this phone at home for entertainment purposes to save my main’s phone battery health. And I’ve been using it for a long time and I’m pretty sure it used to play 1080P 60FPS video on youtube using brave browser with no problems. Recently it’s been reducing video to 720P. Bear in mind I’m talking about 60FPS video. 30FPS 1080P plays with no issues.

Here are the screenshots

have you tried turning off hardware acceleration in Brave settings, system?

Yes, turning off hardware had no effect.

Turning off HW acceleration will cause perf issues The lack of network activity is interesting.

Does Brave beta work okay? (uses different profile)

Also disabling brave://flags#enable-vulkan and/or brave://flags#disable-accelerated-video-decode

Non-full screen may also impact performance since the CPU/GPU will need to rescale the video.

1 Like

Yes, i did tried Brave Beta as well as Nightly.

Both have problems with 1080P 60 FPS playback.

I actually tried yesterday with disabled brave://flags#disable-accelerated-video-decode and it had no effect.

So i tried brave://flags#enable-vulkan as you mentioned but it also did not gave any noticeable results. I went back and disabled brave://flags#disable-accelerated-video-decode again with vulkan and i’m seeing great results. 1080P 60 FPS 10 minute video. Smooth as butter. Only a couple of drops which is normal.



After disabling flags “Vulkan and Decode” youtube 1080p 60FPS plays smoothly but embedded videos(MP4) on other websites wont even load.

I guess i’ll be using FF. It reminds me of my Windows media set-box issue a few years back. All of sudden started noticing high cpu usage, stutter, frame drops… turns out recent chromium update made older hardware unsupported to use vp9 codes . So i had to install h264ify extension to use gpu acceleration. The Devs are definitely manipulating with the software to make non computer people think that their system is outdated and it’s time to cash out. No wonder Microsoft jumped on chromium as if they don’t have enough manipulation power over user through it’s miserable WIndows Update. Sure everything is in (EULA) whether you like it or not but still…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.