Brave won’t launch on Windows 10 after update

Description of the issue:

I restarted the PC today. It is a Lenovo X1-Extreme running Windows 10 Pro 64-bit. When I logged back into the computer, I launched Brave. It asked for my password to update (as I don’t have my daily driver account on the PC set with administrator privileges). I entered my password so that it could update. Then I tried opening Brave again. Upon seeing the outline of the browser window appear, the window closed immediately. I thought that it had to do with the update still going, so I waited. I opened Brave again, the window briefly appeared, but just the edges with the inside white and blank, then it immediately closed. I repeated this action multiple times. The browser window would appear on the desktop for less than one second every time before closing. I tried running Brave as administrator and that worked. However, all of my bookmarks were gone as was any other information associated with my previous use of the browser. I closed the window and tried opening Brave normally again. It closed immediately. So, launching Brave normally no longer works and doing so as administrator puts Brave back at square one for me.

How can this issue be reproduced?

  1. Without handing you my computer, I have no idea how you can reproduce this. Maybe try running Brave after updating it today?

Expected result:
It closes immediately

Brave Version( check About Brave):
Version 1.3.113 Chromium: 80.0.3987.87 (Official Build) (64-bit)

Additional Information:

I discovered another post about the same issue after I made this one, sorry! That said, for anyone that happens upon this one, I found what appears to be the fix for me in this thread: Brave crashes immediately

As soon as you get yours fixed, be sure to back up your bookmarks! I am going to do the same right now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.