Brave wallet doesn't conect with Uphold account

I have one verified account in Uphold, but when I try to verify my Brave wallet connecting it with my Uphold account, a message appears saying that
“Please try again when you are done verifying your ID on Uphold”, but that step has already been done.

@GuillermoJ , @Chocoholic (of interest)

I am NOT an expert, re Brave Rewards, Gemini, and Uphold. I may EDIT / UPDATE the following information, at any time - as I learn more.

The following is an initial attempt to remove obstacles and improve Internet / network communications, between a Brave Rewards user’s Brave Browser installation . . . and:

  • Brave Rewards functions that are parts of the Brave Browser installation
  • Gemini
  • Uphold

Given that the Brave Browser installation is on any of Linux / Mac / Windows computers.

Detailed Verification Guidance for both Gemini and Uphold - the info is at their websites - is referenced at the end of the following info/steps. IF a problem is actually at, or suspected of being at, Gemini or Uphold, then you might scroll down and consult that guidance, first.

All of this, requires careful reading and study of the steps, plus the routines for verification at Gemini and Uphold.

You may find value in the reading and study, and otherwise stick with adjusting only the site-specific Shields (Lion icon) panel at the right end of the URL address field.

These steps assume that you normally have / leave Shields UP.

These steps assume that you will use a Brave Browser > New Private Window in order to connect to:

  • Gemini
  • Uphold

The selections of sources for Cookies and JavaScripts, are the result of monitoring Internet / network communications with Gemini, Uphold, and GlobalID (used by Uphold).

Again, I am not an expert; and, I do not have accounts at Gemini nor Uphold; but, I wondered what I would do, if I did have accounts:

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

Go to tab Advanced

  • Set ‘Time range’ to: All time
  • DISABLE: Site and Shields Settings

Enable or Disable any other settings, in that window, as you may.

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

In a Brave Browser > New Window, return to: brave://settings/clearBrowserData

Go to tab On exit and DISABLE: Site and Shields Settings

Enable or Disable any other settings, in that window, as you may.

Click on the “Clear data” button.

In a Brave Browser > New Window, return to: brave://settings/clearBrowserData

Go to tab Basic - and:

  • Set ‘Time range’ to: All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

Restart Brave Browser.

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]brave.com:443 as the site, but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for all of the following [some may be potential] sources of cookies:

  • [*.]gemini.com:443
  • [*.]global.id:443
  • [*.]uphold.com:443
  • cdn.uphold.com
  • exchange.gemini.com
  • trends.uphold.com
  • wallet.uphold.com
  • www.gemini.com
  • www.global.id
  • www.google.com

(Occasionally, I may find a new source or possible source; and then I update that list.)

While you are at: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Remove all: Sites that clear cookies when you close them

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]brave.com:443 as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Repeat those steps for all of the following [some may be potential] sources of javascripts:

  • [*.]gemini.com:443
  • [*.]global.id:443
  • [*.]uphold.com:443
  • api.uphold.com
  • cdnjs.cloudflare.com
  • cdn.uphold.com
  • exchange.gemini.com
  • mp.gemini.com
  • static.gemini.com
  • support.uphold.com
  • trends.uphold.com
  • use.typekit.net
  • wallet.uphold.com
  • web-wallet-cdn.uphold.world
  • www.gemini.com
  • www.global.id
  • www.google.com
  • www.gstatic.com
  • www.uphold.com

(Occasionally, I may find a new source or possible source; and then I update that list.)

You might also, in a Brave Browser > New Window, go to: brave://settings/security and:

  • Disable: Use secure DNS

If you have the Uphold app, uninstall that app.

In a Brave Browser > New Private Window, go to either host:

  • https://www.gemini.com
  • https://uphold.com

IF Uphold, see their instructions: How to verify your identity

  • https://support.uphold.com/hc/en-us/articles/202766795-How-to-verify-your-identity

Uphold Non-Supported Jurisdictions:

  • https://support.uphold.com/hc/en-us/articles/360026786712-Non-Supported-Jurisdictions

Uphold info at Brave Help Center:

  • https://support.brave.com/hc/en-us/articles/360046470011-How-Do-I-Verify-My-Uphold-Gemini-Account-

When the dust settles, install your Uphold app (if applicable).

IF Gemini, see their instructions: Account Verification

  • https://support.gemini.com/hc/en-us/sections/1260802766949-Account-Verification

Gemini Status: https://status.gemini.com/

Gemini Areas of Availability:

  • https://www.gemini.com/areas-of-availability

Gemini info at Brave Help Center:

  • https://support.brave.com/hc/en-us/articles/360046470011-How-Do-I-Verify-My-Uphold-Gemini-Account-

PS - For Android users: