Brave V-Sync Nvidia - Background Application Max Frame Rate

Description of the issue
Brave will not run at current monitor refresh rate if Nvidia Control Panel - Background Application Max Frame Rate is set.

Steps to Reproduce (add as many as necessary):

  1. Set your monitor refresh rate to 144Hz
  2. Open Nvidia Control Panel - Manage 3D Settings - Global Settings - Background Application Max Frame Rate – and set it to 30 FPS.
  3. Open Brave
  4. Go to and notice Brave running in 30FPS mode.

Actual Result (gifs and screenshots are welcome!):
Brave is running at 30FPS

Expected Result
Brave should be running at monitor’s refresh rate e.g 144Hz

Reproduces how often:

Brave Version(See the About Brave page in the main menu):
Version 1.46.140 Chromium: 108.0.5359.99 (Official Build) (64-bit)

Reproducible on current live release (yes/no):

Additional information:
I’m using Windows 11 Version 22H2 - Build 22621.963
RTX 2070 - Driver 527.56

1 Like

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

1 Like

Thank you for your reply! Indeed that solves the issue for now but not the underlying problem.

Edge browser somehow manages to default to the monitor’s refresh rate with hardware acceleration enabled even when Background Application Max Frame Rate (Nvidia Control Panel) is set to 30FPS.

Background Application Max Frame Rate is really useful when Alt-Tab-ing out of a video game as it limits the game at 30FPS while minimized saving both energy and heat by having the GPU no longer render the game at max frame rate since I am not actively playing the game.

I tried to get some attention to this issue in another post. The bug affects Youtube, overal Brave responsiveness and mouse gesture extensions. Both Edge and Chrome don’t suffer from this, so it’s not an underlying Chromium bug that could not be solved or anything.

My workaround for the time being obviously it not to disable hardware acceleration in Brave, as this would be detrimental for anything but bug reproduction. I also don’t like to disable the NVidia feature globally. So instead I set up the Brave profile in NVidia’s settings to disable the Background Application Max Frame Rate only for Brave. This seems to work, but practice will have to show if it is a viable long-term workaround.


Thank you for your suggestion! I followed your advice and set up a custom Nvidia profile for Brave and disabled the Background Application Max Frame Rate and it works just fine.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.