Brave stops after booting Mac

Is Brave not compatible with Catalina, yet? I start Brave and after about 5 seconds it just quits.

@TexasJimReyna,
Are there any crash/error messages after the browser launches? Additionally, if you right-click --> Open new Private window, does the browser crash in the same way?

I get a dialogue box that says, Restore Pages? Brave didn’t shut down correctly. Open Startup Pages. Restore.

I uninstalled and reinstalled and still get the same thing.

The box stays up about 5 seconds and then Brave just shuts down. No error messages.

@TexasJimReyna,
That’s very strange. Did you try opening a Private window?
Do you have any extensions installed?

It doesn’t stay open long enough to do anything.

Can you please tell me if you have any extensions installed in the browser? Additionally, if you right-click the Brave icon and select New Private Window

, you won’t need to open the browser first to test this.

That option is not available on the mac

@TexasJimReyna,
The image above was taken from my macOS (Catalina, up to date). Can you show me what you see when you click on it?

When I go to Applications in the dock and right click on Brave Browser nothing happens.

When I go to finder in applications drawer and right click, I get the below:

In my Application folder on the dock, right click on Brave Browser does nothing.

From Finder, right click gets this:

@TexasJimReyna,
Clicking on the icon in the dock doesn’t do anything?

Clicking on it opens the program which shuts
down in 5 sec. But right-click does nothing.

@TexasJimReyna,
Can you open your system Activity Monitor and check and see if any Brave processes (including updaters/helpers) are running and if so, kill those processes. Then try to relaunch/right-click.

Nothing running for Brave in activity monitor.

Okay, so this is weird. It’s working now. The only thing I did differently is when it loaded, I kept on clicking in the browser window. It stayed on. Beats me. I closed it down and started it again and it worked okay. Go figure. Thanks for all your input and help.

Jim

@TexasJimReyna,
Glad it started working and happy to help. Please let me know if the issue crops up again so we can further troubleshoot. I’ll leave this thread open until the end of the day. :slight_smile: