Application Not Responding (Won't Load)

A couple days ago my Brave browser was loading really slow and some pages wouldn’t even load so I re-installed and now the browser won’t even load at all…

This is extremely frustrating because I have all my tabs opened to the couple dozen pages I use every day for my work and now I can’t even access these pages…

I have deleted and re-installed the app 3 times already and still nothing… Please help!

This may have something to do with the sites you’re opening the browser to. Can you try launching a Private browsing window (you can right-click the icon in the dock, then New private window) and tell me if it crashes in the same way?

Thanks for the suggestion but it’s definitely not the sites because I haven’t had any problems the past year… I’m thinking it might have something to do with updating to Mac OS Catalina a couple days ago… I wouldn’t even be able to try what you suggested because the browser never even loads when trying to start it… FML

You can launch a private browsing window from the start by right-clicking on the icon and selecting New private window from the context menu. Are you saying that, if you try and launch Brave in the way I just described, the browser still never loads?

Screen Shot 2021-03-31 at 12.25.01 PM

There is no option to launch Brave like that from the icon…

Screen Shot 2021-03-31 at 12.27.22 PM

Every time I try to open it shows this

Thank you for the information.
I know this may seem silly, but can you please try opening Brave from the Applications folder directly (instead of from the dock icon)?

If that does not work, can you please open the macOS Terminal and enter the following command (press Enter afterwards):

open -a "Brave" -n --args --incognito

Screen Shot 2021-03-31 at 1.17.20 PM

Still nothing

Thank you for the confirmation. I’ve reached out to our macOS team about this. In the meantime, can you please tell me the exact macOS version you’re using?

1 Like

Screen Shot 2021-03-31 at 4.26.32 PM

Thank you. I know that you said you have already un/reinstalled the browser, but when you did this, did you also delete the associated data in

/Library/Application support/BraveSoftware

Delete the Brave-browser folder in here, delete the application, empty the trash and re-download – let me know if this does the trick.

There is no brave browser folder because I use an app called App Cleaner that deletes all the files together… I’m pretty much outa luck at this point… I love using Brave Browser so I’m really bummed out…

So I just did a complete search for Brave Browser on my mac and I was able to delete a file that was in my trash… I downloaded again and now it works finally… Thanks for all your help, I appreciate it!

I’m glad that worked but that’s crazy – can you tell me what the Brave related file you deleted was?

Honestly I don’t remember… If it happens again I’ll let you know…

1 Like

Thanks for the update either way.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.