Brave STILL not updating automatically, also have not received rewards since june

Hello, I previously wrote a topic that stated that my Brave browser would not update. Somebody responded to me suggesting that I download the update straight from github. This solved my issue until I closed Brave Browser…

After re-opening brave browser, it returned to the old update. Also, I have not received rewards since June. One more thing - my browser also logs me out of all of my accounts upon closing… I have settings set to NOT do this, and it does it regardless…

I am growing pretty frustrated with this and about to call it quits… Any final advice?


Just skimmed thru your other thread, don’t think this was asked previously: what version of macOS are you on?

I guess, I got the same problem since two days. My brave is updated. And got twoconnected devices and on the other it’s getting updated.

MacOS version: Big Sur 11.6

I also use Brave on my phone, and it works flawlessly…

So I updated my Brave. As I’m using Ubuntu I did it via terminal. And now it’s working fine. Hope it helps.

Also, my mobile brave is not working properly. It’s requesting me to connect to uphold and that was my previous problem in desktop.

Also what worked for me was - sudo apt-get update

sudo apt-get upgrade

The following didn’t work for me - sudo apt-get install --only-upgrade brave-browser

Have you tried to restart the browser, and see if it is still on the updated version?

It’s working for me after I updated with - sudo apt-get update

sudo apt-get upgrade

I rebooted the laptop.

Version 1.32.73

I tried that many times, it is still saying: Version 1.28.105

Ah yes, you’re making a good point here @ImGodsPlan . When you install the browser thru your operating system’s package management system (which is the normal process) then you are reliant on that pkg mgmt tool to handle your app updates. So, if you want Brave to automatically update, you’d want to configure your Ubuntu package manager to handle that.

1 Like

On mac laptop my brave is
Version 1.31.87

I’m not sure what your deal is here @raho , sorry - I don’t have a mac system to test with. I realize some of this is backtracking a bit but here’s what I would suggest:

  1. Do you have any 3rd-party firewalls or anti-virus/security tools installed that might be blocking it?
  2. If you are using SecureDNS, shut it off and see if Brave will auto-update
  3. Check, or try posting on, the Brave Browser subreddit and see if others have had this issue. Feels like something others would have seen and maybe it will be an easy fix.
  4. If you don’t get anywhere with 1-3 and you do decide to continue trying, it might make sense to do a complete uninstall and then reinstall from again. But back up (or Sync) your data first of course.

This is just not worth it anymore for me…

After dealing with these issues for months, and having no real help from community, I am parting ways with the Brave browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.