Brave still does not save passwords

I had enquired about this issue before in 2019. It still persists. Has any solution been found?

Description of the issue:
Brave does not save website login passwords.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Login to a website, youtube, forums, etc…
Brave asks wether to save the password. Confirm.

Actual Result (gifs and screenshots are welcome!):
Next time I open Brave and go to the site, I need to manually login again.
Brave asks (again) wether to save the password.
Rinse repeat.

Expected result:
Brave saving passwords and remembering them next time I open Brave and visit the site.

Reproduces how often:
always

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS 10.12.6 (16G2136)
Brave new version and old version:
Brave Version 0.70.121 Chromium: 78.0.3904.70 (Offizieller Build) (64-Bit)
and
|Brave|0.27.3| |V8|6.9.427.23| |rev|2df8cb1||Muon|8.1.8||OS Release|16.7.0||OS Architecture|x64||OS Platform|macOS||Node.js|7.9.0||Brave Sync|v1.4.2||libchromiumcontent|69.0.3497.100|

Additional Information:
I originally installed the older version of Brave on a user account that does not have admin rights.
On that account, Brave did save passwords as expected. At some point, Brave started running out of memory regularly and crashed every day.
I continued using Brave without update on another user account (with admin rights).
There, Brave did not have the crashing problem, but it never saved website login passwords on that account.
Yesterday I installed the latest version of Brave on the user account with admin rights. Unfortunately, the new version of Brave does not save website login passwords either – at least not on the user account on which I installed it (this is the account with admin rights. The original older version of Brave was initially installed on the other user account, without admin rights).

I examined the unix rights of Braves files in the Library. The directories have read/write permissions for the account where I am using Brave (old and new version. old version installed on other user account. new Brave version installed on this account).
So that does not provide any clue what is going wrong.

link to the entire conversation from 2019: Brave does not save passwords